0 to 60 with OSX, remaining questions (#4 being the big one)


#1

I think I’ve flashed my CHIP right with the Headless 4.3 no-fastboot (the only one I could get to work).

My questions:

  1. If it works with “Headless 4.3 no-fastboot” that means I have an OK cable… right? So why wouldn’t it work with any of the other options? Just a duration or baud thing?
  2. Once installed, is the “no-fastboot” any different than the regular? (It is only something that matters during the flash, or is it not “fast booting” on every bootup?)
  3. What does flashing with 4.4 give me that I can’t get from running apt-get? Firmware updates?
  4. Er… um… how do I get in? headless setup describes how do log in from a linux host, but I have no idea how to do it on OSX.

My previous experience was with OSX->Raspberry Pi, which was a snap: Plug in Pi to ethernet, SSH to raspberrypi.local, done. But with the C.H.I.P. the only connection at the beginning is the USB, so I need to… er… terminal in? Which means I need to find the USB something using this random driver?


#2

I can take care of 4 for you.

Hop onto the terminal and run ‘screen /dev/tty.usbmodem[TAB] 115200’ (hit tab there because I’m not sure what number it is for you. If it’s like mine, it’s tty.usbmodem1421)


#3
  1. Not necessarily. Without fastboot, it’s going much slower. On a mac, usually trying twice, or using a USB2 port or hub fixes things.

  2. It’s the same. Only matters during flash.

  3. New kernel. Most important are changes or our HDMI and VGA DIPS.

  4. if memory serves, on osx, once it boots you should find CHIP by:
    ls /dev/tty.usb*
    and see what it shows
    and then
    screen /dev/tty.usb 115200


#4

Regarding 1, I’m in the same boat as you (MacBook Pro). It seems to be related to USB3. People have had luck with attaching a USB2 hub and flashing through that. I have not been able to flash anything but no-fastboot images myself, but I’ve got a cheap USB2 hub coming tomorrow and I’ll let you know if that did the trick for me.


#5

Success flashing when using a different wire + a different USB hub that I found in the bottom of a drawer. (yay!)

Now I need to get to it. Nothing showing up for ls /dev/tty.usb* All I’ve got is:

/dev $ ls tty.*
tty.AmpedUp-AMP-SPP          tty.Bluetooth-Incoming-Port

I remembered to take the jumper wire out.
HOWEVER… When connected through the old hub, I noticed that I plug the CHIP into the computer, wait ~20 seconds, and it turns off? Maybe a power draw thing?
When connected directly to the computer it stays on. So the hub is required for flashing, but is un-good for connecting…?

Well, whatever the reason, plugging directly into the Mac fixed it.

Then I used screen /dev/tty.usbmodem1423 115200
which was fine until I ran nmtui - which was all garbled, and then I was stuck in “screen”

And if you bail on the program it is still running in the background, and will cause a “resource busy” - which you fix by running
lsof | grep usb
then
screen -S [THE SCREEN ID] -p 0 -X quit

So acording to http://wiki.geeky-boy.com/w/index.php?title=CHIP_startup I should be using cu

sudo cu -l /dev/tty.usbmodem1423 -s 115200
sudo nmtui

then use arrows, tabs, enter to configure it. :slight_smile:

inet addr:10.0.1.14

sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install libnss-mdns
sudo apt-get clean
sudo rm -rf /var/lib/apt/lists/* /tmp/* /var/tmp/*

then I can ssh chip@chip.local
yay!