3D Acceleration for C.H.I.P., Improved Web Flasher, and Alpha C.H.I.P.s are back!


#21

Here’s a secret to try: Assuming you’ve got a Hynix NAND, you can go to:
http://flash.getchip.com?nand=Hynix_8G_MLC
and it will assume you’ve got a Hynix and let you download or flash images without going through the detection step. If you’ve got Toshiba NAND (newer CHIPS that are just arriving), you can try:
http://flash.getchip.com?nand=Toshiba_4G_MLC

Let me know how it goes.


#22

there use to be a way to download all the images on a page without going through any steps is that still avalible


#23

You can try what i just posted above about passing a nand parameter. If you’ve just received your CHIP, it’s a toshiba. Otherwise, it’s a Hynix.

Because we now have to support multiple nand types, we need to know what kind of CHIP you’ve got because the images are, unfortunately, not compatible. The gory details: The initial check that you see now starts up CHIP in FEL mode, loads and executes uboot, which will save nand info to the uboot environment. It then writes the nand values (and serial number) to memory. It then resets the board which goes back to FEL mode where the nand values can be read. From that, you should see only the appropriate images to flash for your type of nand.


#24

is there a way to download just the images without a chip connected i cant seam to find one all i want to do is download the image it used to be you could download all the images at [ flash.getchip.com](http:// flash.getchip.com) right but now it dosent seam like you can


#25

Currently you need to connect your CHIP. If it’s not detecting your CHIP, then it’s a driver or permission issue. See to “more info” on the top of the page for issues like that.


#26

So - I got past that stage by using another computer (i.e. another Linux desktop using Google Chrome)…

Now I’m trying to download the new image for no-limit GUI - and I’ve tried about a DOZEN times and it always times out!

I’ve tried 4 times using Google Chrome and maybe 8 times using wget - and it always errors or times out :

Saving to: 'gui44NoLimit_Hynix_8G_MLC.chp’
gui44NoLimit_Hynix_8G_MLC  30%[==========>                          ] 202.56M  6.82KB/s   in 14m 12ss
2016-11-12 21:51:06 (243 KB/s) - Read error at byte 212395652/688860858 (Connection reset by peer).

And after that - it won’t resume - so start again… driving me nuts!


#27

would you happen to have a windows box in the house? I have not tried the new flasher yet. maybe just … Alittle scared but I’m going to try it out and report back (I’m running Manjaro Deepin edition) going to flash my spare chip with the new 4.4 and try some VGA dip

edit: hmm it seems to be sitting at the getting details state as well. Ill try howies link to skip it as I know its the old 8GB nand

edit: now I can get to the flasher but when I try the 4.4 GUI 3D image it fails very quickly just saying

MD5 Hash:

eddit3: looks like its getting along by manualy downloading the image. but its taking a long time to cal. the MD5 hash (though thats more then likely because that kind of thing is crippling my poor shiitty PC )


#28

I tried the secret, downloaded the image, and am now stuck MD5 Hash: calculating - for over 15 minutes.


#29

Ca you share *.chp filles by torrent? It will be much faster and better for everyone.

Translation

177KB/s - 33.9 MB of 657 MB, 1 hour left

AmazonAWS server can be used as web-seed


#30

sitting there for about 2 hours but CPU is pretty much 100% so I’m assuming it is still working on the MD5 hash
(note I have an OLD pc)


#31

In my case, I didn’t know I needed to click the button to start flashing. Clicked it an hour ago. Chrome has been using 25% of the CPU for 10 minutes. Estimated time remaining has stayed at 7:22:38 and flashing is at 0%.


#32

yeah it looks like CPU usage fell off for me too…weird… are you using windows?


#33

I’m using Win10 on a dual core i3.

Flashing failed, so I closed the browser and restarted. Flashing is now at 20% with 8:08 remaining. Chrome is using 25% of the CPU.


#34

ah okay. I am running Manjaro Linux (Arch based) can’t seem to get anywhere going to try with the Chip-SDK see if that goes well


#35

This worked after several tries.

Is there documentation on the changes in the latest version?

Any progress on User images? I have hours of setting up to do…

Anyone have a serial driver for Win10 and instructions on how to get it installed? I have a hacked driver, but I don’t see a device in Device Manager to modify; and I’m expecting Windows to complain about it not being signed.


#36

Is the NTFS-3G module in this build finally working again so i can write stuff to my external usb drive?


#37

Maybe a stupid question.
But what is the status of the kernel, 1-wire, ADC, PWM, i2c, spi, compiled modules (webcams, joysticks, NTFS, fuse, Arduino etc. etc.) in the “new CHIP release”?

Or is “this hassle” only about to play 3D-Quark and maybe to get 8GB of NAND on the existing 4.4 ?

/Marc


#38

I don’t know, but I heard somewhere on this forum, that most of updates is included.


#39

in MY case, it was “get a functional C.H.I.P” as my C.H.I.P shipped without the drivers for the HDMI adapter. (bag, dip, I can’t remember what marketing name it has.) As it won’t display at all on PAL out of the box and flashing was instructed on the bag. Then I hit the dreaded ‘FEL lock’ and so on.

I am also very much wanting 3d acceleration as I plan to use it for that. Not quake, but demos.

I can, if it would help, give you directory listings of the libraries / firmwares / lsmod and similar, though I’d do that in a separate thread. Just ping me as to what you’d like to know and I’ll capture it for reference.


#40

I cannot use torrents, and don’t wish to, so I could not contribute to that. I’m ok with placing them in standard http or ftp storage, but not any form of torrenting.

I do have a few of the .chp files downloaded and would be able to archive them somewhere if that is ok with the folks at nextchip.