Anyway to SSH with out any DIP's?


#2

Have you connected your CHIP to your local WiFi network? If so, you should be able to SSH into it from a partner PC. What have your tried? What were the results? What makes you think you need anything more than just a CHIP to network into it?


#3

It’s already setup. Just find out the chip IP address. I use an app called fing on my phone. Then do this from another device:

ssh chip@XXX.XXX.X.XX

Marty


#4

That’s the thing, how can I get it to connect to my wifi with out connecting to a monitor? If I can SSH into it somehow by connecting it directly from my computer that would be great then I can configure it.


#5

Aha … the meat of the question. You didn’t say you had no monitor :slight_smile:

When a CHIP is supplied to you, it doesn’t know which WiFi network to connect to and, if that network has a password, what the password should be. As such, you MUST login to the CHIP in order to configure its networking. What then are our options for logging in? The first is to attach it to a TV and keyboard and boot it up. On the TV you will see the output and through the keyboard you can connect it to a network. Following that, whenever you boot the CHIP, it will be networked.

But … if you have no TV or keyboard, all is not lost. What you now need to do is connect your CHIP to one of your local PCs using a serial cable. Personally, I would use a USB->UART connector with the USB end plugged into my PC and the UART RX, TX and GND connected to the header sockets on the CHIP U14 header. With that setup, you can then attach a serial terminal emulator such as mobaXterm or Putty running on the PC to the UART port and will be supplied a login prompt. User/password is “chip/chip”.


#6

If we boot up a virgin CHIP, would it show up on “fing”? Does CHIP connect to open WiFi networks? Is it connectable via Bluetooth? I’m curious how “fing” could get an IP address from CHIP … because that would then imply that a virgin CHIP actually has an IP address … and if it does … what access point did it connect to? Is it acting as its own access point? … looking forward to studying this notion.


#7

Aw man I have one at work. I’m curious if you can some how emulate the usb port to be a COM port.


#8

What about the build-in USB to serial!

I had no problem to connect the CHIP to my Mac or my linux computer.

I know that there is a problem in windows with the 4.4 version but you should see the chip and connect via the com port. Check your device manager!

Putty is able to select a com port!


#9

I have heard stories that if one plugs a USB cable into the microUSB port of the CHIP and the other end into a PC that the PC will show up a new COM port that will indeed be a serial connection to CHIP. However, in my environment which is a 4.4 Kernel and Windows 10, I could not get it to work and a different thread said that 4.4 kernel wouldn’t drive the USB->COM correctly.


#10

I have heard stories that if one plugs a USB cable into the microUSB port of the CHIP

Check some post on this forum. They have the solution!


#11

Wooo! I found a way

  1. Setup a linux vm ( Linux mint )
  2. Booted it up and connected the CHIPs usb to my VM
  3. sudo apt-get install screen
  4. Did a sudo screen /dev/ttyACM0
  5. Great success.

#12

Bravo Tony!

Yes USB to serial is simple. This remember me that I had to do a document about USB cluster.

https://bbs.nextthing.co/t/network-speed-between-c-h-i-p-s/8177/3?u=danjperron

They are still connected together and working but the performance is bad since the USB bandwitdh is cumulative.


#13

Glad u got it. I read vnc is the way to go. I bought a composite video converter to VGA box for $20 that should do the job to connect to my monitor. I know-twice as much as chip but will also connect my beagle bone black and raspberry pis.

U can use fing now if connection isn’t static and moves to another IP address.

I thought u already had this connected before, so fing wouldn’t of helped initially.

Marty


#14

Try this, dunno if it can be done in win10


#15

If you are Mac user, I’ve posted some instructions that may help:

Mac to C.H.I.P. USB OTG serial connection

Once you make a serial connection, you can then use the included instructions to connect to your Wi-Fi network and SSH into the C.H.I.P.


#16

Re: I had no problem to connect the CHIP to my Mac or my linux computer:

I am trying to ssh from my mac to my chip with the end result being “wrong password” but I am using chip as the password. I was wondering if you had any problem with password for the chip?

keith


#17

On your Mac did you type

> ssh chip@chip.local

#18

These are great instructions. However, I’m stuck because the successfully flashed CHIP (with 4.4 GUI) doesn’t show up in the /dev/tty list (as a USBmodem) at all when reconnected without the jumper (I’ve verified that the board boots by connecting it to a TV monitor separately.)


#19

Might want to check your USB cable. Some are power only. That would be my quick guess. Let me know if that turns out to be the issue. If not, I’ll try and find some time to look at other common issues. Someone else might chime in as well.


#20

LIkely not much of a help, but my weekend project(s) was to flash both of my CHIPs to the newer 4.4.13. I used the no limit one in both cases. Then connected one to my macbook where the usbmodem was found and worked.

ls /dev/tty.usb*
returned usbmodem1423 in my case

the other one I left connected to my Win10 box and, from devices and printers, found it was on COM3 and used Putty to connect.

In both cases, I just ran sudo nmtui to set up connection to wifi, did so, then shut them down and connected them to a power strip in my “network closet” (okay, a shelf in a spare bedroom).

then, just used my mac terminal to connect ssh chip@10.0.1.76 in my case. Logged in, ran updates and set up vnc, http, etc for the servers that I use them for.

Again, likely no help other than to confirm that the 4.4 GUI works.


#21

Even dumber. I hadn’t labeled the individual chips and wasn’t using the one I thought. They are now labeled and working as expected. Thanks again for the clear instructions.