[APT] Pocket Home (Marshmallow edition)


#490

Well that is great news! Hopefully this will make it into a future version soon! With only three items currently listed, there’s plenty of room in the Advanced Setting menu. Anyway, as always, keep up the great work!


#491

When I try that command I get:
bash: cd /home/chip/RetroArch && ./retroarch.sh: no such file or directory.
I also tried it from the command line and I get the same error.
I used single quotes, triple checked my spelling.
I appreciate your help with this, I am learning.
Ray


#492

I am a newbie trying to get mine and my brothers Chip computer Working on my Laptop screen . I just flashed 4.4 GUI on my two chip computers I was able to get one chip in my ubuntu terminal to connect to wifi . But after that step I can’t seem to stay in the Chip computer menu I have to close terminal and reopen . And type Sudo Screen /dev/ttyACM0 and it just goes to the network and shows I am connected to wifi . Is there a way from that same terminal page to be able to Get My Chip computer to display on my Laptop screen Please Help I am stuck


#493

@Howgoit you have a few options. you should try installing ssh so you can ssh from your computer into chip. though I have a feeling what you want is to have a GUI interface from chip on your laptop for that you have to setup a vnc server on chip and use a vnc client on your laptop


#494

I installed ssh but instead of it installing on CHip I think it installed to my ubuntu . As every time I got into chip on the terminal it would connect to my wifi then I couldn’t type on the terminal screen and had to close terminal and reopen a new terminal which took me back to my ubuntu . How do I stay in the CHip in terminal to enter the sudo apt-get install ssh command and other commands on my chip. And How do install a vnc server or vnc client ? My tv is not connecting with the RCA video cable and won’t display only lines . I have tried multiple cables .


#495

Hi, maybe this is not the best place for your questions because mostly people interested in @marshmallow’s Pocket Home replacement are visiting here. I’all strongly advise you to open a new topic for your questions.

Having that said, maybe I can offer a little help. Since I understand that you have no way to get your chip display something over the nice pink cable that came with it, your best way to get things running is by SSH’ing into your chip. You can SSH over wifi, but you’ll need a keyboard, mouse and a working screen to set it up. But there’s another way, where you can do everything from your laptop. When you connect a USB cable from your laptop to the charging port of the chip, you can create an ACM connection to your chip, which is almost the same as an SSH connection. After the terminal shows on your laptop, you can set up wifi, SSH and VNC and you don’t need the USB cable anymore (except for power ;)).

Good instructions for setting up ACM can be found in @NinjaKun’s thread.


#496

Nomachine is the best remote desktop tool I’ve used. Works on chip too. Download the AMRv7 deb file from their website :

https://www.nomachine.com/download/linux&id=1

and install from terminal on the chip with sudo dpkg -i filename.deb

do the same on the laptop for whichever OS you have on it, then connect to the chip’s IP address from the nomachine client on your laptop.


#497

This runs perfect for me, hats off to the marshmellow guy.


#498

Thanks for the tip! I’ve been using many remote desktop solutions, including VNC, RealVNC, TightVNC, UltraVNC (all VNC versions are slooowww), Radmin (fast but less flexible than VNC), TeamViewer (works through firewalls as long as their server is not down), Microsoft Remote Desktop (only for Windows as target systems) and a few others which I’ve forgotten. Nomachine looks promising so I’ll give it a try, it looks like it’s got the best solutions for a few of the reasons why I sometimes need remote desktops.


#499

Thx Squirrel61 much Appreciated for the help . And for all the other posts . Sorry I got off subject but I Appreciate everyone’s help. Marj


#500

Thx for the help Micronaut I will try that Marj


#501

how do i get shortcuts to work? i put in what i would put in the console for it to work but nothing happens. it loads for a bit and then nothing!

Oh and also…how do i change the time?


#502

I tried to search but since this thread is very huge I couldn’t find this question:

Is there a way to change the image that is in the login screen?


#503

I’ve not been able to make teh time work right,
to change it I think it is

sudo dpkg-reconfigure tzdata

it doesn’t seem to work when I reset it,


#504

alright thanks. btw do you know how to fix the shortcuts for pockethome? the problem only seems to happen on programs that work in the console natively like roguelikes for example.


#505

not sure exactly Im still having a bit of trouble fixing some icons,

this is what @marshmallow showed me and I think it is how I got Frotz to launch from an icon

vala-terminal -e “cd folder && ./binary”
, as this will launch a terminal and then execute directly the command.

I wish it was more helpful but I don’t recall exactly what I typed to get the icon to work, lol


#506

thanks it worked! except for frozen depths wich has an executable i need to open in the terminal. i tried putting in the directory but it just opens the command line.

EDIT: nevermind it dosent work anymore on any of em. it just opens up the console and thats it.


#507

You can try “shell”: “vala-terminal -fs 8 -g 20 20 -e /file path to exe”


#508

This is probably a question that has been answered before but what do I need to do to create another app icon for my different doom wad files I have so that way I can launch them individually from the home screen


#509

Nevermind I figured it out. I just had to write it like I do in terminal to launch it