Configure VNC without display


#1

My new C.H.I.P. came today! Now, I’m trying to configure VNC, since I do not have a composite monitor handy. I installed tightvncserver via the terminal, using the USB serial capability. However, when I connect with VNC, all I get is a gray screen with one window, XFCE Terminal. How can I set up VNC to connect to the full desktop shown in the C.H.I.P. docs?


Wifi: VNC won't allow connection
Won't boot to ChipOS
Easy way to screenshare?
#2

Hey, congrats on the new chip!

Be sure to open your VNC session as the user: chip and not: root. As that would result in showing you an unconfigured desktop. Aside from that, could you post a screenshot of what you’re seeing?


#3

Oh, duh, of course. I was logged in as root@chip since I was following the documentation on connecting via USB serial. Logging in as chip@chip and starting the VNC server worked. Now I just got to figure out how to make it start automagically…


#4

C.S.N, Did you create the install of tightvncserver or find it on the web. What tools did you use if you created it?
J.


#5

It is actually in the repos: sudo apt-get install tightvncserver

Then it’s a matter of getting it to auto start. There are multiple tutorials on how to install vnc on Ubuntu Server, so I followed one of them. Most of them use vnc4server rather than tightvncserver, but the basic steps are the same.


#6

C.S.N, Thanks, after I posed I figured out I needed to do a apt-get update to get to the apt-get install.


#7

I installed vino that attaches to the console display - works without a video display connected (as long as in run level 5)

if interested, also install dconf-editor via apt-get to configure vino-server if you wish to disable encryption, set a password & not prompt locally to allow connection. After starting dconf-editor - press Ctl-f and search for 5900

for autostart, run ln -s /usr/share/applications/vino-server.desktop .config/autostart/vino-server.desktop from the chip home directory


#8

[quote=“c.s.n, post:5, topic:1334, full:true”]
There are multiple tutorials on how to install vnc on Ubuntu Server, so I followed one of them.[/quote]
@c.s.n.
Can you please provide a link to the set-up instructions you used for tightvncserver? I have been searching for the a usable set of instructions but none of the ones I have found seem to work. As I am having problems getting this to work on my new V1.0 chip, it would be really helpful to know that I am starting with a working set of instructions and can therefore determine if I might in fact be having a “picnic” (problem in chair, not in computer)
Cheers


#9

I didn’t find a step-by-step tutorial, but I think this is what I sort of went by. Of course, some of the steps are not necessary, but I used it as a general guide, making modifications where needed.

P.S. Never heard of the picnic error; I’ll have to remember that one!


#10

Many thanks for your instructions! I followed: http://www.penguintutor.com/linux/tightvnc and it was painfree. I am updating chip as I type this!

Now I can fool around with CHIP until I find a way to use it as a 3D printing server.


#11

Thanks for the post! I also followed http://www.penguintutor.com/linux/tightvnc. My desktop is looking different over the VNC connection, however:

This is what /home/chip/.vnc/xstartup looks like:

What do I need to change to make my VNC desktop look like in the documentation?


How to access CHIP from a laptop [SOLVED]
#12

Thank you to those that posted their reference material.

So as it turns out, problem was in chair…

When you first run tightvncserver, you are asked to create a new password. So I did… Fast forward to when I was trying to connect using my client on another computer. For reasons still inexplicable to me, I used “chip” as the password to start the connection instead of the one I specifically set-up for tightvncserver…

Moral of the story, when you set up a password, expect the computer to want you to use THAT password(it seems so obvious now).


#13

Yea… I’m a total Linux noob so I don’t know what I did to make it look like that. Now I am missing all folder icons and can’t start the GUI for the synaptic packet manager. For me CHIP works fine but Linux is hard. Sometimes I loose WiFi connection and have to switch it off and on again or launch the USB serial terminal via putty.exe to use nmtui to reconnect. Chip documentation needs to get better. As a noob I don’t know what is chip specific and what not.


#14

Jumping in on this conversation.
I have downloaded tightvncserver on my chip and the viewer on my Windows 7. When I try to connect using IPAdress:5901, I always get a connection refused. I then tried chip.local:5901 and I get a connection party did not respond. Did any of you come across this issue?
Thanks!


#15

I connect using ipadd:1 or chip:1(Using Zero Conf Networking) not chip.local:5901. Give that a try.


#16

So I tried chip:1 on my Windows and I get “The request name is valid, but no data of the requested type was found”. Also, when I try chip.local::5901 I get “connected party did not respond properly after a period of time”.
However, on my work computer (mac) I am able to connect with chip.local::5901, but I get a grey screen. I know I need to open the session as chip not root, but I am afraid I don’t know how to do that.
Thanks for your help!


#17

And I got it to work! Turns out hostname -i was giving me a different IPAddress than ip addr show dev wlan0. Also, only the Java viewer works for some reason. Finally, if I do sudo tightvncserver, I am able to login in as chip and not root.


#18

I have an issue. I installed the TightVNC server on CHIP and TightVNC Viewer on Windows 10.
Right now I cannot connect to my CHIP, Also I even cannot ping my CHIP from Windows machine.
Anybody has any idea what I am missing? Thanks


#19

I can connect from a WindowsXP machine running TightVNCViewer to CHIP running tightvncserver… I see the CHIP desktop, can run apps, etc. over the link. When I try (via the VNC link) to cause the CHIP to reboot or shutdown, however, this never succeeds. The CHIP just keeps on running, ignoring my command. I get the same result when I try to do a shutdown from the GUI as when I send this command via the terminal emulator:

sudo shutdown now


#20

I have the same issue. I am not sure it has to do with VNC. But when I do a

sudo shutdown

note without the “now” it says it will shutdown 1 min after the command was issued, and then it does shut down.