Customize the Hell Out of Your PocketC.H.I.P. — Install Doom & Give It an Icon on the Home Screen


#1

Thanks to forum user @marshmallow’s work, it’s easy to modify the PocketC.H.I.P. home screen and add custom content.

In the latest blog post, learn how to install @marshmallow’s software and install Doom with a custom icon.

Happy hacking!


A few questions about the Pocket Chip power
#2

#3

Those directions do not work for me:
chip@chip:~$ ./install-pockethome
Downloading new package link
–2016-07-12 15:39:15-- https://drive.google.com/uc?export=download&id=0B1jRc4IqT9kiSVVIOE8wd2w4Zkk
Resolving drive.google.com (drive.google.com)… 172.217.4.78, 2607:f8b0:4006:806::200e
Connecting to drive.google.com (drive.google.com)|172.217.4.78|:443… connected.
HTTP request sent, awaiting response… 400 Bad Request
2016-07-12 15:39:15 ERROR 400: Bad Request.

Checking if new version is available
./install-pockethome: line 6: gt: command not found
./install-pockethome: line 6: /tmp/version: No such file or directory
./install-pockethome: line 7: gt: command not found
./install-pockethome: line 7: /tmp/link: No such file or directory
./install-pockethome: line 8: syntax error near unexpected token ;&' ./install-pockethome: line 8:(diff /tmp/version ~/.pocket-home/.version && echo ‘Already up-to-date.’) || ’

However, the directions directly from the author’s post do work:


#5

Thanks for letting me know @emdkay. I’ve changed the step and verified that it works.

Best I can tell, there was something funky going on with the syntax highlighting plugin introducing weird characters to the copied text. Unfortunately, when I wrote the project, I didn’t catch the problem, since I had copied the script from the website to a notepad on my laptop, and then to the SSH session.

Sorry for the confusion and thanks for alerting me!


#6

Shouldn’t this be “Customize the hell into your PocketCHIP”?

:stuck_out_tongue_winking_eye:


#7

Actually, I would have said "Customize the sht out of your PocketCHIP." Because we certainly don’t want any sht left in there. Yuk.


#8

But then isn’t the implication that NTC shipped us sh*t…
I don’t think we want that either. :grin:


#9

Hey, I’ve picked up a whole lot more sh*t just getting through life then I ever had when I was manufactured.


#10

Guys …

I was making a Doom joke.

:grimacing:


#11

Here is a video tutorial


#12

Newbie question.
Is it possible to run *.sh from an icon?
I tried putting ./*hhgg.sh and it didn’t work, but it does work from the command line.
I put this on where you type in the command. Doom, SCUMMVM and Vice all work but not *.sh files.


#13

When you are in the terminal and you write ./hhgg.sh, ./ means “current folder”. So I guess you are in the default folder (/home/chip) when you type this. So in the command field of an icon, you should type /home/chip/hhgg.sh :wink:


#14

That makes a lot of sense. I’ll try it later tonight.
Thank you.


#15

I tried putting /home/chip/hhgg.sh and it didn’t work.
When I tap the icon, I get the spinning icon for a few seconds and then nothing.
I tried with a couple of the .sh files I have and I get the same result for each.
I double checked my spelling and path and tried a few different times.
I know I must be missing something really obvious.
I have done the sudo +x chmod /home/chip/hhgg.sh


#16

Is it a terminal application? In other words, would it work for you to launch it inside the terminal app?

I created an icon for the rainbowstream twitter app by adding “-e rainbowstream” to a copy of the vala-terminal command.


#17

Can you try @jhnolan 's solution ?
In the command field, type :
vala-terminal -fs 8 -g 20 20 -e "/home/chip/hhgg.sh"


#18

That works.
I tried two different .sh files and both will now execute.
Thank you.


#19

Your video tutorial really helped me i wish there were more thank’s