Customizeable Home Screens



I agree, this really deserves it’s own thread.


Perhaps make a page on the wiki with the essential instructions, updates, and such, and reserve the new thread for discussion, suggestions, etc.?

Such a page could be a general “Pocket-Home Forks” page, with information about everyone’s various repos for comparison.



Surf honestly isnt overly usable unless we built a version with things like history support and whatnot. surf on it’s own si very very barebones and needs either shell scripts, patches, or wrapper applications to do anything for it outside of the actual browsing.

While I do agree that surf is there and built-in, it would need some work to be really usable for anything more than a quick browse of a single page.


Is the issue with it deleting the desktop assets fixed? I have tried re instaling it and i can download it but when i try to do the give it permissionns step it says "chmod: cannot access ‘install-pockethome’: No such file or directory.

I know its there I can open it from the downloads folder and read what the file says.

Is it not working anymore?


I have now included the assests in the deb, from the feedback I got, it’s working :slight_smile:

Are you sure you have cd in the Download folder ? Can you see the install-pockethome file when you type ls ?

PS: If you have an SSH server on your CHIP, you can have access to it “in case of”. I have opened a new thread ([APT] Pocket Home (Marshmallow edition)) where you can follow easily the updates :wink:


I am unsure what you mean,


When you enter the Terminal, did you first typed cd Downloads ? The command ls gives you the list of files of the folder you are in



I was able to follow the instructions on your repo

And successfully built and installed the pocket-home app.

I was able to add and delete a seventh icon successfully using the “Personalize” and trash can, well done sir!

One minor suggestion, can you make the trash icon have the lid open when it’s red, the black/red toggle is not as obvious.

Thank you for all the work you did!


Whenever I try to use chmod, it says that pockethome is not a file or directory. I made sure I was in the home directory when I downloading it. What could be the problem?


@TA651 This is quite old now, check the last version: [APT] Pocket Home (Marshmallow edition)


That’s the problem. I used the installation instructions from that page. Is there something that I need to change when I use wget? Or do I need to use chmod differently. I’m new to Linux so i’m not quite sure.


The option -O of wget lets you name the file you downloaded, so after executing the command I gave, you should have a file called install-pockethome. To check the files in the current folder, type ls.
Then if the file is indeed here, you can use chmod +x install-pockethome (because the file should called install-pockethome)


Apparently -0 is not a valid option :disappointed:


It was O, not 0 :joy:


But now there are problems with ./install-pockethome. It says there is a syntax error on line one. :frowning:


This is abnormal :neutral_face:
What is the md5sum of your file ? (md5sum install-pockethome)
If it’s not equal to 67a28cda89b7f90a91070dc3a0614791, redownload


That worked!!! Thanks for the help!


Hi, I just found this forum and its amazing, one problem is that after I get to tar xvf pocket-home-personalize.tar
Then you get the binary (pocket-home) im lost on what to do next. To anyone who can help me thanks in advance.


Welcome @Isaac.Taylor !

This thread is kind of very old, I opened a new thread only for this custome home, you can see here, there are instructions on how to install :wink:
[APT] Pocket Home (Marshmallow edition)