Emulators on PocketCHIP (my tests)


These are my results on how emulators work for me on PocketCHIP.
Higan: run “sudo apt-get install higan” (without quotes)
I use Mednafen for everything else, but downloaded simply for the SNES emulator. It works, the higan-balanced version runs at around 15 FPS, and the higan-performance runs in between 15-20 FPS. So for now it’s slow. (Tested with EarthBound)
NES: A Whopping 5 FPS (on higan-balanced)
higan-performance: FPS UP!.. by 1
Mednafen: sudo apt-get install mednafen
Surprisingly GBA works well. However SNES ends with a SIGABRT message (if it’s fixed I’ll post the results [tested with Mother 3)
NES works flawlessly on mednafen. (Mother 1)
By these results, GB and GBC should work well on mednafen and not higan.
Comment with your results!

(and yes, I am a mother fan)


I have not had any luck with either higan or mednafen both install on my PocketCHIP but neither will launch. FCEUX works great though for NES


You need to change the video to SDL. There is an option in higan to change it in advanced options, and you can find a tutorial for mednafen here: Mednafen (Emulator) configuration (GBC/GBA/SNES/NES)
Install SDL with the command “sudo apt-get install libsdl2-dev”


Yeah I did that and yet mednafen stilll would not open. Higan opens but I can’t do anything with it.


You have to add roms, mednafen does not have an interface but for me I can go to the file manager and double tap the rom and mednafen will run it, in higan press library then click on any console then click Import.


I have roms. loaded and yet nothing. I know i need roms to run it.


I have tried to launch with the SNES, NES, and GB roms off my flash drive. Yet no luck with mednafen. Like I said before FCEUX works perfectly as NES emulator


Hmm works fine for me, sorry it does not work for you. However I can relate to SNES roms not working.


Ah ok SNES is not working? Ok good to know that was my main concern I wanted to play some of my favorite SNES games. I guess for now I will stick with NES


Any reports of a Sega Genesis\Megadrive emulator working? How about a Turbo GFX 16\PC Engine?


I followed the guidance here and it worked fine…once I found the write config file location.


What about VirtualBoyAdvanced? I’m asking because i know that this emulator has multiplayer compatibles :blush:


I don’t know. I’ll try when I have time


I have followed those instructions as I had stated before on this thread. I have had no success.