Game (and emulators) compatibility list


#12

ScummVM

ScummVM is set of old game engines, mostly for Point&Click adventures. Everything works good, but you may have some problems with scale (read above post). If you want to know more you can ask Google or Wikipedia.
Games with resolution less than 480x272 (like 320x240) works on PocketCHIP.


To install ScummVM just put sudo apt install scummvm in terminal. If you’ll install BaSS, FotAQ or Drascula it will install automatically.

  • Official F.A.Q.
  • Freeware games (multiple versions and languages)
    Or you can use sudo apt install [name],
    [name] may be:
  • beneath-a-steel-sky for… Beneath a Steel Sky!
  • flight-of-the-amazon-queen for, yes, Flight of the Amazon Queen.
  • drascula for Drascula: The Vampire Strikes Back (:flag_gb:)
    • drascula-music for sound files
    • drascula-french - :flag_fr: | drascula-german - :flag_de: | drascula-spanish - :flag_es: | drascula-italian - :flag_it: | select for your language.
  • List of compatible games

#13

eduke32 also works.

It needs to be compiled from source…


#14

Oh also I tried compiling Commander Genius (which is a Keen engine)

It doesn’t compile at the moment. It segfaults the compiler which is new, I’ve not had the pleasure of segfaulting g++ during a compile…

Oh well, I’ll see if I can cross-compile something static.


#15

OpenXcom :ballot_box_with_check:/:black_square_button: :iphone: - (TBS With humans fighting aliens) - Instructions for install here | Please also see here


#16

Any NES emulators?


#17

Here ya go. You’re welcome.


#18

Tumiki Fighters :ballot_box_with_check: :iphone: (Side scrolling shooter/SHMUP with building block polygons… YES, POLYGONS! Shoot the enemies, collect their wreckage to upgrade your plane. Only issue is button layout. Dpad to move, Z to shoot.) - sudo apt-get install tumiki-fighters

Parsec 47 :black_large_square: :iphone: (Vert wireframe 2.5d bullethell. It “works” but it chugs really hard.) - sudo apt-get install parsec47

Torus Trooper :red_circle: (Ride your ship inside a torus. Launch gets seg fault) sudo apt-get install torus-trooper

Tenmado :ballot_box_with_check: Unsure about other screen compatibility, doesn’t fit on PocketCHIP (Shooter loosely akin to Radiant Silvergun or Iakruga. Shoot similar colored objects to get chain bonuses.) sudo apt-get install tenmado


#19

Rick dangerous :iphone: :ballot_box_with_check:
wget http://oph.mdrjr.net/meveric/binaries/xrick/xrick.tar.gz
tar -xf xrick.tar.gz
cd xrick
./xrick -fullscreen


#20

I’ve used Stella, the Atari 2600 emulator, successfully on the CHIP. To get the older version that’s in Debian Jessie, just “sudo apt-get install stella”.

To run at a reasonable speed, you need the “-video software” command line switch. Running a ROM from the command line works, but to use the launcher in “-fullscreen 1” mode to pick from ROMs, you need to have your video mode set to at least 640x480. The default NTSC and PAL output modes are a little bit smaller than that to handle overscan, so they won’t let it start up due to not having enough screen space for the launcher.

To fix that problem, I rebuilt Stella from the latest source (https://sourceforge.net/p/stella/code/) which took a few hours to build due to it being a LOT of C++ source, and modified the minimum FB height value to 400. The current top-of-tree source has a problem with debugging output that really slows it down, so I had to redirect all output on both stdout and stderr to /dev/null when running it. So far, that version has worked well for all the classic 2600 games that I’ve tried, but I’ve not yet tried some of the latest homebrew ROMs like Space Rocks! that use a mixed 6502 and ARM mode that’s enabled by the Harmony Cartridge.


#21

I’ve built UAE4ARM but haven’t tried it yet (the gui launches but didn’t have time to sort anything else out) so if people could give it a whirl that would be great


#22

Exult - Ultima VII: Black Gate, Serpent Isle - works without any issues even on PocketChip’s screen


#23

For Sam and max hit the road, I know I need scumm, got it, does it matter what version? Mac dos ect. How do I use it just open it with scumm?


#24

I think we’ll be seeing that a lot until there’s a GPU driver unfortunately.


#25

the version of the game itself shouldn’t matter as it only uses the data files with graphics etc. and those should be identical between version. It certainly supports e.g. Atari ST, Amiga and PC version of the older games.


#26

For parsec47

  cd 

  sudo apt install git build-essential cmake libx11-dev --no-install-recommends

  wget  -O glshim.sh http://paste.lisp.org/display/325260/raw

  chmod +x ./glshim.sh 

 ./glshim.sh

wait until compiles

  ./glshim.sh  '/usr/games/parsec47 -lowres' -tinygles

Enjoy blasting fast GL->EGL software wrapper. It should work for simple 2D stuff.


Voxatron on ARM
#27

I installed dopewars easily and am already playing. It’s the gui version though a curses/ascii one could be installed as well. Not sure which is more desirable.

I just did sudo apt-get install dopewars


#28

Can you share the eduke32 package compiled?


#29

after updating to the new pocket chip flash, with 3d, touchscreen doesn’t seem to work with scum vm anymore.


#30

How is it broken? No response, or cursor moves too quickly, or…?
ScummVM seems to be working fine with the touch screen on my (recently updated) PocketCHIP.

It might be a difference in configuration. I did have problems when trying to run full screen. Are you still testing against Sam & Max?


#31

Just no response, when you touch the screen in scumm first time with the mouse pointer on it shoots to the top of the screen and stays there, a usb mouse works fine though