Headless (no screen) setup for wifi and VNC


#4

Call me crazy, but has anyone had their etc/network/interfaces file cleared out without them doing anything? Mine did.
I had setup my wifi to auto login with password, but then today, I went to clear it out and the whole file was empty as soon as I loaded it in Nano.

Anyways, would someone be so kind as to tell me what the default contents of etc/network/interfaces is? I remember there were a few lines at the top…

Thanks in advance,
Rich


#5

This is the entirety of the file:

# interfaces(5) file used by ifup(8) and ifdown(8)

Include files from /etc/network/interfaces.d:

source-directory /etc/network/interfaces.d


#6

Can you please check if you can start synaptics packet manager gui via the “computer things” menu? Also can you shut down your chip via the GUI? I followed those instructions too and it seems they produce some permissions problems.


#7

Does anyone knows the solution for this?


#8

@lionas - Changing “WanterBy” to “WantedBy” may help.

P.S. Yes it is a bit of a poor message out of systemctl, when there clearly IS an [Install] section.


#9

@abinning - Thanks for these instructions.

But I notice there is a problem (or two) in your service spec:
You have “Type=” entered twice.

And also, contrary to @blacksmithtb the “tightvncserver” DOES fork, so my understanding (See https://wiki.archlinux.org/index.php/systemd) is that the type should be Type=forking.

For me, if I set it to Type=simple, IT DOES NOT WORK. Type=forking does work.
Weird that 2 of us get such different behaviour. (Maybe systemd or tightvncserver has changed at some point?)

So, with Type=forking I finally have this auto-starting.

P.S. The chmod should also be 644, not 755.
Having the x bit on a service spec actually generates a warning in dmesg.

P.P.S. It is actually important who you are logged in as when you first run “/usr/bin/tightvncserver” - It writes into your home directory. The instructions above are ambiguous in this regard - root or chip? It NEEDS to be chip or chip won’t get a vnc password.

P.P.P.S. - I think you need a final “systemctl start tightvncservce.service” (or a reboot) to actually get it running.

What a waste of several hours… Anyone from CHIP listening? - Why-o-why is this not configured out-of-the-box??? The lack of a proper digital screen connector is a major short-coming of CHIP. (But great that is saves $$$).
Having good GUI remote access from power-on should be a no-brainer, should it not???

Cheers. Hope I have helped some other poor souls out there in CHIP-land.

@abinning - Could you please update the top post above, as other resources point here.

For clarity, here is the final service spec that works for me:

[Unit]
Description=TightVNC remote desktop server
After=sshd.service

[Service]
Type=forking
ExecStart=/usr/bin/tightvncserver :1
User=chip

[Install]
WantedBy=multi-user.target

#10

You are correct it should be type=forking.
I can not seem to find the edit button for the original post, but I did update the G+ post.
Well, I can edit this post. No button on original, perhaps an admin can remove the 2nd type= line and changed dbus to forking?


#11

Instead of opening the /etc/network/interfaces file by hand, run nmtui as root.

You’ll select your network, enter the password, and you’re done.
It will connect automatically on boot.


#12

For the bit about setting up wireless from a text console, I couldn’t get the info here working - Neither the way at the top, or using nmtui, left me with working wifi.

There seems to be better info here now: http://docs.getchip.com/#connecting-c-h-i-p-to-wi-fi-with-nmcli
That worked straight away.


#13

Thanks for the VNC setup instructions! I’ve transferred them to a wiki page, incorporating the later fixes.

Update: Now I’ve also edited the You Don’t Have A TV? page, incorporating the rest of the info from this page. Hopefully I didn’t get anything wrong (I fixed a few nits, like having to give the full path to ifconfig.)


#14

I tried the above and this following error

● tightvncserver.service - TightVNC remote desktop serverghtvncserver.service -l
Loaded: loaded (/etc/systemd/system/tightvncserver.service; enabled)
Active: failed (Result: exit-code) since Wed 2016-07-13 10:02:48 UTC; 10min ago
Process: 727 ExecStart=/usr/bin/tightvncserver :1 (code=exited, status=1/FAILURE)

Jul 13 10:02:48 mini01 tightvncserver[727]: You will require a password to access your desktops.
Jul 13 10:02:48 mini01 tightvncserver[727]: Password: Password too short
Jul 13 10:02:48 mini01 systemd[1]: tightvncserver.service: control process exited, code=exited status=1
Jul 13 10:02:48 mini01 systemd[1]: Failed to start TightVNC remote desktop server.
Jul 13 10:02:48 mini01 systemd[1]: Unit tightvncserver.service entered failed state.

Any clue how to resolve this ? Thanks


#15

Did you run tightvncserver once from the command line to set the password?


#16

Yes I did. If I manually typed to run tightvncserver, it worked but just not as a service.


#17

I just wondered since the error says “password too short.” Have you tried a different password? Maybe something simple (no special chars, etc.) and 8 characters long?


#18

That would certainly be a logical conclusion.

Yup, my password is currently 8 characters which seems to be the upper limit.


#20

Okay, I just reflashed my CHIP with 4.3 and started everything over again. It seems to be working now. Earlier I logged in as root and the tightvncserver.service file user was set to chip. And probably a host of other things which causes the issue.

Sorry guys.


#21

Glad you got it sorted.


#22

Thank you soo much :heart:


#23

About the last few posts above - I think the critical thing is You have to be logged in as the right user the first time you run tightvnc server.

See my post from May 13. You want to be logged in as “chip”. Consider “su -l chip”.


#24

Has anyone successfully made guacamole work on their CHIP? I haven’t started, yet, but it’s on my todo list.