How to install XFCE or any other DE


I might give this a try! does it work well? now if I could just get support for switching to hdmi dip and be able to power the CHIP from just usb

4.4 xfce missing panel?

it does,battery and backlight indicators are not working atm but at least you can move the windows :wink:


Can you share any photo to view size window etc?



did this today still needs alot of playing with need UI stuff resized
@Hark0 here are some pics

EDIT: Reducing DPI and panel size helps Alot though some windows are still pretty tricky
EDIT2: @UnixOutlaw I know you wanted the 4.4 GUI on pocketchip this seems to be working okay and you can easy log out and change between XFCE and the pocket-home. now If i could just get HDMI DIP And get the chip working outside of the pocket part I would be a really happy camper to be able to change between the two

EDIT3: windows don’t seem to be respecting the screen size even when maximized

EDIT: pics reduced sized sorry cant make better pics cant change screen brightness down atm.


I’ll stick with 4.4 GUI on PocketCHIP for the time being…

One tip - some things are nearly impossible to configure inside CHIP - so I installed XRDP, and tweaked various things like DPI settings (impossible to get to on pocketCHIP) from a remote desktop session…


awesome tip! though I just hold alt and grab the window to pan around had no issues reducing the dpi and such from pocketchip. just alot of windows refuse to size small enough even so. I might just flash 4.4 on my pocketchip and go from there I really want to have hdmi dip support so i can pull chip out and use hdmi and switch back

edit: adding tag @UnixOutlaw for some reason replying doesnt work for me alot of time via my phone



Are impressive!



Old dog learn new tricks :

sudo apt-get install e17

you will have to disable the compositor atm and choose the mobile interface

if you don’t know enlightenment , you should.


I wqs thinking about that it works great on my tiny 2.8" adafruit screen on my rasp pi


Hi, I´m having issues with the window manager.
Enlightenment won´t start because of the standard wm is running and xfce has the same issue.
Strange is that the windows don´t seem to have an wm on them because there is no bar on top of the windows.

I used a fresh flash with the above
sudo apt-get remove --purge lightdm
sudo apt-get install lightdm xfce4 xfce4-session

your pics show that an wm is running… what is wrong with my chip?


you have to reboot and log in


Sorry, but wth is “compositor atm”??


you should disable it (software?)


By default Window Compositing is turned off… I’d recommend leaving it that way - until at least GPU drivers are mainline, and even then, I’d still recommend leaving it off…

I just did the purge of lightdm, but also purged awesome, and then installed lightdm, xfce4 etc (this also installs xfwm4)… However - PocketCHIP is just sitting there displaying the CHIP logo splash in the centre…


One thing that was a little bit alarming - was this :

Processing triggers for initramfs-tools (0.120+deb8u1) ...               
update-initramfs: Generating /boot/initrd.img-4.3.0-ntc                  
Warning: root device  does not exist                                     
DTB: sun5i-r8-chip.dtb                                                   
Installing sun5i-r8-chip.dtb into /boot/dtbs/4.3.0-ntc/sun5i-r8-chip.dtb 
Taking backup of sun5i-r8-chip.dtb.                                      
Installing new sun5i-r8-chip.dtb.                                        
Installing sun5i-r8-chip.dtb into /boot/dtbs/4.3.0-ntc/sun5i-r8-chip.dtb 
Taking backup of sun5i-r8-chip.dtb.                                      
Installing new sun5i-r8-chip.dtb.                                        
flash-kernel: installing version 4.3.0-ntc                               
Taking backup of zImage.                                                 
Installing new zImage.                                                   
Taking backup of sun5i-r8-chip.dtb.                                      
Installing new sun5i-r8-chip.dtb.                                        
Generating U-Boot image from /boot/initrd.img-4.3.0-ntc                  
Image Name:                                                              
Created:      Wed Aug 24 03:11:49 2016                                   
Image Type:   ARM Linux RAMDisk Image (uncompressed)                     
Data Size:    6673924 Bytes = 6517.50 kB = 6.36 MB                       
Load Address: 00000000                                                   
Entry Point:  00000000                                                   
Processing triggers for libc-bin (2.19-18+deb8u4) ...                    
Processing triggers for dbus (1.8.20-0+deb8u1) ...                       
Processing triggers for systemd (215-17+deb8u4) ...                      
Processing triggers for menu (2.1.47) ...                                

Right after installing xfc4…

Looks like I’m up for a flashing… I don’t want to switch between PocketCHIP interface and vanilla xfce, I just want xfce on ChipOS 4.3, so I can run synergy and not have to use the hideous keyboard on PocketCHIP, or have like 6 keyboards spread across my desk!

I tried GUI 4.3 in the PocketCHIP chassis, the only way I could access it was over Serial USB gadget…



It´s the display manager … in lightdm, top left I can choose whichever
desktop I like.

Didn´t know that. Last time I fumbled round with X confs, such a thing did
not exist yet.
Let me think… that was on XFree86 3.3 running on kernel 2.0.33 or so.
THAT was fun trying to make a monoscan 22"CRT working on THE latest nvidia
riva128 :slight_smile: good old times!


I researched window managers for screen size issues. I settled on one for screen readability and wrote about it: Matchbox Window Manager on PocketCHIP. It forces large application windows into pretty small space, including GUI buttons that were getting lost at the bottom of windows.

Matchbox window manager on PocketCHIP

I tried this on my pocketCHIP and restarted, but now the screen isn’t turning on. I can still ssh into it, though.

Are there any additional steps on 4.4 I should be doing?

EDIT: It looks like there was an error with the remove/install I didn’t catch the first time. Via ssh I ran:

sudo apt-get remove liblightdm-gobject-1-0 liblightdm-gtk-greeter
sudo apt-get remove --purge lightdm
sudo apt-get install lightdm xfce4 xfce4-session

and then rebooted. Darn, I was hoping that would get it going, but it didn’t.


Running into this issue also. On first boot it was fine, but when I rebooted again I get the chip splash screen, then a black screen. Did you resolve your problem or just reflash?


Yeah, unfortunately, I wasn’t able to track it down. I ended up reflashing.

If you have anything important on there, or want to save your rc.local or other config files, you can try to ftp or ssh into it.

In case you’re having trouble finding what the IP of your device is, you can use this:

nmap -p22 --open -PN -sV -oG ssh_hosts

After booting, even though the display is off it should auto-connect to a wifi network if there is one within range in its memory. Just replace the IP at the end with whatever pattern your network uses and run that command on a computer connected to that same network. Your chip should display as “Shenzhen Rf-link Technology” in the output. And the default username and password is going to be “chip” and “chip”.

If you’re on Windows and don’t have nmap installed, you can find it here:


Thanks, nothing important, still trying to nail down a good config.

I’m a little unclear about what’s necessary to get XFCE4 working though,
since I had followed the directions in a thread about that.

When I first try xfce4 on a fresh 4.4 install it loads but never displays
the panel…