I can't seem to get mednafen to work, even if my life depended on it


#1

Alright...

So I've been banging my head at getting Mednafen to work on my pocketchip. It seems no matter what, I just can't get it to work. I've done the exact same process on my Lubuntu machine, and it works perfectly fine. I've followed 0xicl33n's super helpful guide. And other various troubleshooting posts. Could someone help me figure out what's going on? Here are the steps I take with a fresh chip.

I start off with a fresh flash

First thing is sudo apt-get update.

Then I install SSH and x11vnc so I can control chip from my PC

sudo apt-get update again just to be sure

Next, I'll stick a ROM into my home folder

Next, sudo apt-get install mednafen libsdl2-dev


Installs successfully without any errors.

Ok, now I'll run mednafen... ??? Alright, run mednafen with a ROM

Chip doesn't seem to recognize mednafen.

I've even tried this with higan to no avail. However, the exact same process works just fine on my Lubuntu PC... What am I doing wrong?

#2

Get pocket installer by @iker and @Dmian it has retroarch in it which runs more reliably on chip. Just search for pocketinstaller.


#3

Well it seems that the install process did not create the bin or some link. Have you checked the two urls shown to see if the app exists in there?

Check /usr/games/mednafen and /usr/bin/nes to see if the app exists there. If it does, you should be able to run it from there…

Try elevating to sudo and see if the command exists on that level.


#4

It worked!

Thanks a ton! I’m not sure how I missed that nifty program


#5

Glad to be of help!