Just purchased 2 chips and can't get either to work with Windows


#19

I did not hear any sounds when plugging my chip in and I normally do hear a sound when plugging in other devices. I also do not have anything with chip in the name in it. I also don;t have the libusbK Usb Devices tab. In addition, my LEDs don’t flash, they stay solid. It also doesn’t refresh device manager when I plug in the chip so that makes me think that it is having a different problem than you had.

The post failed to send and now it won’t let me send it because it is too similar to prev post that never got posted so I am adding this to the post.


#20

Seems silly to ask, but dod you reboot the computer after installing the drivers? I had this issue, and scratched my head a while. After a reboot, the computer/USB driver found the chip module OK. I used the drivers on the flasher web page.


#21

Yeah I have rebooted several times with no luck, :frowning:


#22

Check Bluetooth, Other Devices etc, keeping in mind that the device name should not even be CHIP it should be Serial Gadget. But it is not even that so you have work a little to get it that way. If it no sound is made by Windows then I would look for any device that is not working properly so it has this yellow triangle with a exclamation point.


#23

You could try using a Linux virtual machine if that’s within your skills. I happened to have a VirtualBox Ubuntu image lying around, so I didn’t bother trying to solve the problem on windows, but just booted that up. It worked without much effort on Linux, even in a VM.


#24

I do have access to an Ubuntu system. Is there a tutorial that outlines the steps to getting the chip working? I couldn’t find one (they seem to all be for windows)

EDIT: Found this: Setting up CHIP as a headless server with minimal tools
got stuck when after typing “dmesg | tail” and having no device anything similar to what he had. I also ran the command before plugging in the chip and after and got the exact same output. I also tried different cables and usb ports.

Follow up question: When you plug in your chip do the LEDs flash or just stay solid. Mine will immediately be solid and just stay solid.


#25

The pink LED is the power indicator, it will be on as long as the device is powered.

On the latest images, the white LED should stay solid at first, but then switch to a heartbeat (two flashes, brief pause, two flashes, etc.) On older images the behavior is actually different.


Alright, so USB serial mode is actually far from the simplest thing to get working. Let’s forget about it for a second, as you’ve tried two other things that didn’t work either.

First, there’s the 3,5mm video out. If this doesn’t work, there’s something quite wrong with your CHIP (either with the hardware of with the software). Did you use a pink cable bought from NTC? If not try plugging the red plug into the yellow input of your tv and vice versa. There’s actually three versions of this cable which all pretty much look the same, but are different in which connection is routed to which connector. One of them just works, one of them works with the red and yellow plugs switched and the final one just doesn’t work (its ground is connected differently), but the first two types are far more common than the last.

Second, the flashing doesn’t work either. I see two things that can help here. One of the problems that the flasher has is that it sometimes get stuck if you don’t restart Chrome. So, if you haven’t restarted Chrome, update the flasher, restart Chrome, then try flashing and if it gets stuck, restart Chrome and try again. (If it gets stuck again, but not at the same point, restart Chrome again and try yet again.)

The other thing that might be causing problems with the flashing is the USB cable. You mentioned you used different cables. However, quite a few cables don’t work for flashing the CHIP and the fact that you were able to use the cable for transferring files isn’t actually a guarantee that it will work for flashing. So, try more different cables. This would also explain why the USB serial isn’t working, so it seems quite likely to me that this is the problem.


#26

4.4 GUI CHIP has flashing white led. Earlier versions and especially noticed on the headless one that they just stay lid. What I think you should do connect Ubuntu machine to an open (without passphrase) WiFi network and plug in the CHIP to USB.

Open Terminal, wait 90 seconds and ssh chip@chip hint: it’s chip.

:musical_note: Shell life, woo-ooo, it’s a shell life :musical_score:

HINDSIGHT:
This would only work on alternatively build system compared to NTC image. One that connects to open WiFi’s if it has no previous connection. Or a system that has been preconfigured to do it and for me this worked because of the latter.


#27

I used a black cable that I found at my house. It looks to be the same as the NTC cable. I really don’t want to spend any more money on this if possible. With my cable, I have tried plugging in each of the three outputs into the video plug on my TV and none of them worked.

For flashing, I have restarted chrome and my pc many times but I still get the same problem.

I have also tried to reflash chip. I connected the GND and FEL pins and then plugged it into my pc. It played a tone and showed up in the flashing tool. It said “Chip detected, reading details from it” It then played the disconnect tone and the flash tool went back to the home page.

It always gets stuck at reading details from chip.


#28

Unfortunately, my Ubuntu machine (16.04 LTS) does not have a wifi card and is connected via ethernet to my home password protected internet (WPA2 Personal).

EDIT: I do have an extra router that I have hooked up the the ubuntu pc and removed the password. The chip is not showing up on the DHCP client table for the router and I get “could not resolve hostname” when attempting to ssh to chip@chip.


#29

As I said, there are cables that look the same, but aren’t. If you have a multimeter, you can find out what type of cable this is. The 3.5mm jack has four connections (a Tip, two Rings and a Sleeve, making it a TRRS connector). For each of the RCA connectors on the other side, use the multimeter to to measure to which part of the TRRS connector the inner and the outer parts of the RCA connector are connected. (All the outer parts should connect to the same part of the 3.5mm connector, as they’re all ground.) Based on that, you can find out whether this is a cable that is usable to connect your CHIP to your tv.

Then it would seem to be the cable. Have you got any other cables you can try?

That is to be expected. The CHIP does not automatically connect to your network. (That also means that the whole ssh chip@chip suggestion didn’t make much sense.)


#30

Yeah sorry about that, I rememberd while sleeping that it is considered sane that programs meant to connect you to the internet don’t do so without you doing something. I guess it is good thing because our devices are not protected by passwords and the neighbours are very curious about which distro you installed.

So you would need one extra step for the ssh connection. Turn on chip, wait 60 seconds then plug in a keyboard.
For headless system type:

  • chip[enter]chip[enter]

For GUI system:

  • [Alt+F3]term[DownArrow][enter]

Then;

  • nmcli d w c “TypeSSIDhere”

#31

Wouldn’t it be chip[enter]chip[enter]?

Really, trying to control a computer that’s not giving any output is really just full of traps. That you cannot see. Or even know whether you have fallen into them or not. I wouldn’t bother with it…


#32

You are absolutely correct. But it is just one little name that we have to sneak to NetworkManagers knowledge to have it accept it as a secure connection. Like for example if you had open wifi named “a” you would only need to manage getting to the Terminal and:
nmc[tab]d[space]w[space]c[space]a[enter]
Now some gamecheats are harder than that.


#33

Case in point: you missed something again. And you wouldn’t have any way to know that was why it wasn’t working, as you would have as much output as you do now. (Oh, and yes, you would have the fact that your CHIP wasn’t connected.)

It should be: nmc[tab][space]d[space]w[space]c[space]a[enter] (I think, I might be missing things too.)


#34

Thank you for your input. You just read what your terminal had written in it but did not document the exact steps of getting there as it is evidenced by the Terminal behaviour. When having only one available command with the beggining letters autofills it and a space with a single press of the tabulator, so you can just go on with your next command.


#36

My bad, I was typing nmt instead of nmc when trying it out and there are links to nmtui that start with nmtui- which is not at all relevant to nmcli. I still don’t think it’s really worth it to try this, but I’ll stop arguing over this and instead focus on helping @Kir13y (once there is something I can say to help again).


#37

I have tried the following cables: Official Samsung Note 4 cable, Sparkfun cable, LG cable, and a bunch of other generic cables. I tried them in both of my USB 2.0 connectors and the Sparkfun + Samsung in a usb 3.0 port in addition to the two usb 2.0 ports.


#38

Plugging in a keyboard and using a command might be the next thing to try. The cables definitely work for power as indicated by the LEDs so I think this is what we should try. What exactly should I type?

Also when I plug the chip into my ubuntu pc that is on a second router (cascading router), should the chip pick up the wifi? It doesn’t show up in the DHCP client table.


#39

Alright, that seems like it should have gotten at least one positive hit among them. Have you tried all these cables for flashing, or just for serial over usb? If the latter, could you try a bunch of them for flashing? (USB over serial has a much more complicated software side, so the flasher is the better way to find a good cable.)

Forget about the USB 3 port. It is actually known to cause problems.

Basically power is the simplest part of the equation.

I believe the default is a dektop install and all my chips are running headless, so I wouldn’t know. I guess following @jwnz’s is the best I can suggest.

No, it shouldn’t.