LittleGPTracker: music tracker like LDSJ (sample based)


#1

Hello,

how about a new tool for composing music on your PocketChip?

I’ve compiled LittleGPTracker: http://littlegptracker.com/

It’s a tracker similar to LittleSoundDJ, but it’s sample based.

You can download it from there:
https://mega.nz/#!0oZR0YhQ!BBfwz5CfQrn0CE-Vy7etfogMxowDDdf1tel6tuiL95A

maybe you’ll need to get the full archive from http://littlegptracker.com/download.php and copy the new binary in it.
And also reconfigure the default keys to your needs (there is a config file on the full archive)


#2

Thanks for compiling LGPT!

I’m getting a “Failed to initialize audio” alert when opening a song. Any idea why?


#3

I don’t know. I’ll try to load a sample tune and check if it works for me or not.


#4

Nice, but how to put the files on the pocketchip plz ?


#5

you can download the file on you computer and extract it, then copy it using whatever you can, for example an usb key.

But i would recommend to install something like this on your Chip for synchronising content:

I haven’t tried yet to load a sample song.


#6

Hi there! I also built LGPT on CHIP, but it’s unable to open the audio device. I tried your binary and I get the same error:

RtApiAlsa::getDeviceInfo: snd_pcm_open error for device (hw:0,0), Device or resource busy.

Please let us know if there’s something you did to allow LGPT to access the sound driver correctly.

See also my thread on the topic: [FIXED!] ALSA PCM device busy error (LittleGPTracker)

Thanks!


#7

I’ve tried with a song I found on BotB (http://battleofthebits.org/arena/Entry/blitter+bater/1480/), and it works, I have sound. I’ve done nothing special, but it might work because I was “forced” to install pulseaudio, maybe it’s the reason it works for me (pulseaudio is so intricated into modern distributions that there are often things which doesn’t work correctly when pulseaudio is not installed)


[FIXED!] ALSA PCM device busy error (LittleGPTracker)
#8

Thank you for the reply! I didn’t realize pulseaudio was missing on CHIP, installed it rebooted and boom: the piggy played audio. Thank you again!


#9

Can’t seem to get the key config correct, it keeps giving me these error messages:
failed to attach event/a to key:0:???a???

Doesn’t matter if I use this format:
KEY_A value=”0” />
or this one:
KEY_A value=”key:0:0” />

Tried putting this in both mapping.xml and config.xml


#10

I don’t use any conf file and I haven’t tried much the software. Seems the “a” / “b” buttons are working, but it’s not very practical so it’s understandable to try to remap them.


#11

Finally, I managed to get it right. Mapped the number keys closest to the “joypad” for the shoulder buttons. Dash and backspace are B and A respectively.

Runs extremely well and as soon as I can get used to only using my thumbs instead mixing in my index fingers, I’ll be spitting out beats like a madman :wink:

A tiny gotcha is the application seeming to override the ctrl+q hotkey to quit an application when running with Fullscreen = YES!

Happy tracking!


#12

Running into this weirdness: it cannot see my mapping file

[MAPPING] No (bad?) mapping file (bin:mapping.xml)
[-D-] Mapping config

But its in there next to bin. Any suggestions?


#13

oddly, I rolled back to the 4gb image and all my problems vanished.

Working:

Bluetooth
Midi Out
Mapping file
Config
Todo: Custom menu
Bluetooth state persistance
Cloud sync to my pigg project folder!


#14

Yo @herrprof, how did it go with the TODO-items? :slight_smile:
Dropbox isn’t optimal for cloud synching imo.
I had a go at Bittorrent Synch a few years ago but I haven’t tried it for my various ARM-units.


#15

I love this idea, But out of curiosity does it support Impulse tracker format and if so, How well? That’s still my go-to tracker after all these years (Well, SCHISM specifically)


#16

Looks like there’s only a build for 64bit Linux and I don’t see any indications there’s an ARM configuration in the repo… But that doesn’t mean it’d be impossible to build for CHIP =)


#17

… Seems like someone already went at it! =)

Hardly think LGPT supports schism tracker files tho…


#18

It just needs to be able to read .IT files.