Mednafen (Emulator) configuration (GBC/GBA/SNES/NES)


#367

Do you have to use a USB to load the games onto the pocket chip


#368

No you don’t have to, I use the scp command


#369

For me, my Legend of Zelda : Oracle of Seasons shortcut reads :
Mednafen ~/home/chip/.mednafen/Roms/LoZ-OoS.gbc

All one line of course, lol.


#370

Dang, guess new users are limited to posting, i was locked out from replying for 11 hours XD

try the full typing of the path? not with the “~”, i unno, that’s the only thing diff, is i used full paths.


#371

yeah thats how i did it, used a lil usb stick i had lying around.


#372

i used pocket-home, lets you have more than just 6 icons, and allows you to change the background, it also adds a % to the battery life and other things.

can find it here [APT] Pocket Home (Marshmallow edition)


#373

mine for seasons is “mednafen -fs 1 /home/chip/.mednafen/ROMS/ZeldaSeasons.gbc” as the path for the icon in pocket-home.

this is off topic, but… for anyone interested.
Also to make an icon that opens the file manager as sudo so you can easily move files around without being blocked, make an icon name it whatever, i named mine “Sudo FM”, and make it’s icon the browse files icon, and set the shell command to “gksu pcmanfm” or “sudo pcmanfm”, and apply, when you click it it will open the file browser with sudo permissions. [ i know it bugged me, so this makes it more easy to move files without having to use terminal]


#374

This is how I roll: :smile:


#375

Hi I just got my PocketChip, very frustrated :slight_smile: is there a topic that explains how to install Mednafen step by step? like what files to download, where to put them on device etc? I tried downloading mednafen_0.9.36.4-1.dsc tried telling the terminal to install it - it seems not being able to see the file, i am sure i am doing it wrong, and just curious - there is not graphic interface to install anything right?


#376

The very first post here is about as step by step as you’re gonna get.

Remember to always start with sudo apt-get update.
As for me, i took the Mednafen cfg file popped in on a usb drive and popped it into my comp where i used notepad++ to edit it.

Edit - Anyone else have slight stutter when playing GBC games?


#377

So, there is a Mednafen GUI available, in this thread, but it’s in 2 separate posts and a bit hard to find, so here’s the details with no assumed knowledge, this is also a lot easier over ssh:

First, here’s the final product in use!

Step 1: In terminal, create some new folders, structure is important here!

cd
mkdir roms
cd roms
mkdir gba
mkdir gbc

Step 2: Put your roms in the correct subfolder, for myslef I upload roms to Dropbox, then use the public link:

cd gba
wget -O fileName.gba http://linkToFile.gba

Step 3: Install zenity, this allows us to use the script we’ll be running

sudo apt-get install zenity

Step 4: Create a script, in our home directory, cd command with no other inputs will take us there:

cd
sudo nano medGui.sh

Step 5: Copy and paste this script into the .sh file we just created and opened, Ctrl+X exits nano and you’ll be prompted to save there. Credit to Slade and soupboy:

#!/bin/bash

cd /home/chip/roms

folderpath=$(ls)

system=$(eval zenity --list --column System $folderpath --width=480 --height=272)

if [ "$?" -eq 1 ]; then
  echo "Cancelled."
else
  cd $system
  files=$(ls -Q)
  rom=$(eval zenity --list --column "Roms" $files --width=480 --height=272)

  if [ "$?" -eq 1 ]; then
    echo "Cancelled."
  else
    mednafen -fs 1 "$rom"
  fi
fi

Step 6: Give the script the correct permissions to execute

chmod +x medGui.sh

Step 7: Run that script!

./medGui.sh

If all went you’ll get a full screen dialogue box to select your games from, I’ve also gone ahead and made a little Mednafen icon for those of you using Marshmallow launcher, the command to run when you add the icon is just ./medGui.sh


Emulator with GUI like EmulationStation
#378

~


#379

Is that an English translation of mother 1+2?


#380

I’m having trouble configuring my Dual Shock 3 controller with mednafen. So far I’ve tried GBA and MD and when I press SHIFT, ALT, 1 to configure the controls, it asks me for each input, dozens of times. I believe the MD emu asked me for the up input, 12 times!

I went ahead and just pressed the same input each time I was asked, but for some reason I ended up with buttons A, B and C, Start, Select and Left, Right working just fine, but no Y axis. Up and Down simply didn’t work. Any ideas?

Also the MD sound was very corrupt. It sounded a bit like it was using the wrong sample rate or something (stuttery and almost “time stretched”)

For the control issue I could perhaps manually edit the cfg, but the problem is that when I look at the cfg file in nano, the strings it has recorded for my button presses are long and confusing. I’m just not sure how to correctly manually edit the cfg file.

Also, if anyone has the correct config settings for full screen mega drive scaling I’d be very grateful.


#381

Exactly! :blush:


#382

Hi guys,

I have been reading the post. Thank you all for this great add-on to the Pocket C.H.I.P. I installed Mednafen + Zenity and with a custom icon it works great!

I have checked NES, GBA and also Metal Slug on Neo Geo Pocket. However this last looks crap, I expected something like Neo Geo as I never played the Pocket one. Do you think we’ll be able to run Neo Geo? Not only for MS, also for one of my favourite games (even if it is so simple): Far East of Eden, Kabuki Klash. Anyway, if it doesn’t work, there is much fun using the other emulators.

I hope to be active round here and perhaps collaborate in something.

Regards.


#383

How i roll


#384

Where did you find it? I’ve only found non translated ones


#385

this right here is FANTASTIC and works so well! it doesnt use much coding and is a a simple bash script, this will be added to the main post


Fast SNES emulation on the PocketC.H.I.P
#386

That’d be rad! I’m not the creator but you can credit:

https://bbs.nextthing.co/users/soupboy/ - Created the script, gave the original install instructions

https://bbs.nextthing.co/users/Slade/ - Fixed the Script