New kernel live in apt repos! Flashable images also online!


Hey C.H.I.P.sters,

We at NTC have been working on getting out a new kernel release for all of you. This new kernel applies to anyone using our last release of MLC images. You should be able to a get this update via apt or by flashing the latest image from onto your C.H.I.P. or PocketC.H.I.P… We will also be releasing updated flashable images very soon that already have the latest kernel installed.

To install from a previously flashed OS, you’ll need to connect your C.H.I.P or PocketC.H.I.P. to the internet. You can find instructions for that in the docs here:

Once online, run the following in a terminal:
sudo apt update
sudo apt upgrade

Then give it a reboot and enjoy your new kernel!

Changes in latest kernel release:

  • Docker container support!
    • I’ve had a lot of people ask me about this for a while now and I’m really excited to finally get this out to you all.
  • DirtyCOW is patched.
    • This was tested using Hypriot’s hypriot/rpi-dirtycow container.
  • Namespaces
  • Various control groups enabled
  • Various networking capabilities enabled
  • OverlayFS support
  • HostAP support
  • More input device drivers (joysticks, gamepads such as PS3/4 and Xbox Controllers)
  • 1-wire modules
  • DVB/TV Tuner modules
  • LIRC module
  • Dummy and Loopback sound devices
  • USB printer module
  • USB ACM module
  • Various USB mass storage modules
  • USB LED/LCD modules
  • SISUSBVGA module
  • FBTFT and its various display modules
  • Ext4 encryption support
  • XFS
  • FUSE
  • NTFS read/write
  • HFS+
  • SMB2
  • ISO 9660
  • Various other small additions

If you encounter any issues with these modules or wish to see others, please file an issue here:

We are working on cleaning up the backlog of issues and making CHIP a better experience out of the box.

Thanks for all of your support,

New direct links for the new kernels .chp images
Lirc Support in Kernel
New CHIP-SDK/CHIP-tools update
Dirty Cow patched yet?
Please add w1-therm kernel module for DS18B20!
CHIP HANG On ffmpeg, liveimage fswebcam


We also received some support over the weekend from our friends at Hypriot:


Awesome update! I’ve been waiting for FBTFT support for a while now. I can’t wait to hook up a tiny LCD to my CHIP.


@zerotri new images are up! Could you update the title/post?


This is awesome news, CHIP just became a whole lot more awesomer!


Finally no need to compile the above modules…


@zerotri I would like to see you guys improve the USB OTG-experience. At the moment CONFIG_USB_CDC_COMPOSITE is built in to the kernel, instead of as a module, so one cannot change USB OTG-mode without recompiling the kernel. There is no good reason for doing this, you could just add the module to /etc/modules by default, if you wanted to.

In relation to the above, though, there’s the issue that the composite-gadget doesn’t work with Windows 10 out-of-the-box; IMHO, you should use g_serial by default, users can always change the mode then by modifying /etc/modules – you could even mention some of the alternatives in there as a comment, if you wished to. Or you could provide a signed driver for the composite-gadget so users don’t need to resort to 3rd-party tools or disable driver-signing.


Has the solved issue Remove 32khz interrupt debounce to deal with NoIntDebounce workaround?

W: Failed to fetch  Hash Sum mismatch

E: Some index files failed to download. They have been ignored, or old ones used instead.

Got this during sudo apt-get update … never seen this one before (i normally update before i install or upgrade anything)… The update was performed just now on a new chip that i got in the mail today. (2 week old order)

Upgrade is in progress at the moment,


Can it do NAT now?.. I.e, does this still happen?

root@chip:~# iptables -t nat -nvL
iptables v1.4.21: can’t initialize iptables table `nat’: Table does not exist (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.



This is great. But it would be great if the output of either ‘uname -v’ or ‘uname -r’ could be made to include the git hash of the kernel tree. Someday it will make someone’s debugging that much easier if they can know for certainty they’re looking at the right source tree.

#13 should put a version number/date on the images, if I flashed yesterday afternoon, and I can’t tell if I have the latest. Without booting it up, and checking versions, can’t get to the firmware page without booting into fel mode.


I think I’m missing something.

On my PocketCHIP, after doing the apt update and apt upgrade, I’m still running 4.3.0-ntc.

Do I need to flash a newer image first and then update? Or do I need to explicitly install the new kernel? If the latter, I see “linux-image-4.4.13-ntc-mlc” in an apt-cache search. Is that the one I want?

Or is this not available for the PC yet?


You need to flash the 4.4 PocketCHIP image first.


great work ntc!

Could we get SECCOMP enabled by default for sandboxing when using chips as CJDNS routers? it would be very helpful for meshnets


Thanks! Has the documentation been updated where appropriate for the new functionality? Where else might we find more details for the new features?


I have been trying to build a kernel with TUN/TAP network Modules with NO success!
I followed all the docs I could find and my kernel with only added the TUN/TAP modules to the Debian LITE .config never boots

Is that module installed with this new kernel? (fingers crossed)

Also, i am cross compiling with Ubuntu 16.04. Is there any other directions for compiling a kernel on Ubuntu out there. I have tried 5 times with no success.

P>S> I Love my 10 C.H.I.P.s


You could try my cross-compiling script. Download and extract it, which will create a directory called chip-compile, then copy /boot/config-4.4.13-ntc-mlc as prevconfig in the chip-compile directory and call ./ prevconfig menuconfig Make your changes, then do ./ build, wait for it to finish, and follow the instructions. It’s quite simple.



Thank you very much. I can’t wait to try it out!

Michael Connors BA.CS.

NOTE: If this message includes a Service Report Please KEEP for your
records. If you make changes to your network and/or passwords please modify
the document(s) attached.