New PocketCHIP, no sound in Firefox


#1

Hello. New PocketCHIP user here. I got my PocketCHIP yesterday and I have some trouble with it. I flashed it with the desktop 4.4 OS and after booting the mouse cursor moves totally in the opposite direction then my touch movement. There is no sound coming from Firefox ( I tried to play a direct mp3 radio stream). I ran the audio test with “speaker-test -t sine” and I am getting a sound in my headphones but the volume control has no effect. There is also no battery indicator so I have no idea how much charge I got in the battery.

How can I fix these issues? Thx


#2

Hi @jolebole,

The Desktop 4.4 image you flashed is not really designed for PocketC.H.I.P., it’s more for running on C.H.I.P. with a monitor, keyboard, and mouse. That’s why you’re having issues with the touchscreen and there is no battery indicator. Some people have modified their settings and are using the Desktop image on PocketC.H.I.P., but it takes a bit of work.

I’d suggest that you flash the PocketC.H.I.P. 4.4 image. This will fix the touchscreen and add a battery monitor. Another cool thing to checkout is PocketHome, a community made project that adds a bunch of features to PocketC.H.I.P…

Hope this helps,
David


#3

I’ll definitely check Pockethome. My goal for the PocketCHIP​ is to use it as a portable linix desktop for basic tasks because PocketCHIP 4.4 OS is kinda limiting for me. I connected a wireless keyboard with touchpad and it works fine but sound in Firefox still doesn’t work.

I also wanna step it up to the 5in adafruit display. I saw it done here and it looks cool.


#4

The easiest way to fix the touchscreen. After upgrading the touchscreen you will have to do this again…

You will also need to update the pocketchip keyboard settings.

I am not sure what your sound issue is off the top of my head but that will at least get you started. There is also a simple battery monitor that works by using the white status LED, but that is just a proof of concept.


#5

I believe this is the reason for your sound issues. Recent versions of Firefox is PulseAudio only. I believe Pocket chip uses Alsa


#6

Thank you for the calibration fix! :slight_smile: For some reason the second command did not work for me. But I used the manual method and its working much better now. Bad news the adafruit 5in touchscreen is ouf if stock lol. You guys bought them all out :wink:


#7

My fault…the second --output-type should be --output-filename

I blame auto correct.