Personalization of GUI


#5

Fabulous hat-tip to the awesome film “Hackers”! What a great background image. Go for the trash - HACK THE PLANET!


#6

You’re doing great work, much appreciated.


#7

**Changing Icons**



Hello Everyone,

So, changing the icons on the desktop has been pretty straight forward.
I kinda just did same thing from before by
editing using nano sudo nano config.json
in the directory /usr/share/pocket-home
I just used the preexisting icons pathway located at /usr/share/pocket-home/appIcons
to replace the default pathway location of the "Get Help"s Icon
which was also located at /usr/share/pocket-home/appIcons
So I basically just changed the gethelp.png name for it to the "webbrowser.png"
and since the original "shell" : "surf" called a local document.
Which is also presaved on Pocketchip and doesn’t require the internet(surf) to use.
I just changed it to open to a webpage instead.

The same method can be done for all the icons so as long as you have the proper shell command for it to execute.

Once you resave the file by pressing Crtl and X at the same time and Reboot the device it should be on your desktop.make sure you save it as the same name - config.json

Next thing is to see about putting more than 6 icons on the desktop.
I will also post a write up on that when I get to it this afternoon.

P.S. The white page takes about 10 seconds to load. You can see the thin orange load bar at the bottom of the screen.


PocketInstaller (v5.0)
CHIP and PocketCHIP - OS differences
#8

When you do changes, you dont actually need to restart the whole thing. If you have terminal access via ssh or local you can simply do

sudo systemctl restart lightdm

and it will restart the gui. Pretty useful for fast testing :slight_smile:


#9

Thanks for the steps!


#10

Here’s my current wallpaper:


#11

Amazing! By the way, what about the D-pad? Is it cool, comfy?


#12

The D-pad is great…it works really well.


#13

When you change it do you change it to "shell : “url” ie… to change the shell to launch iceweasel i would change it to “shell” : “iceweasel” or would i change it to “shell” : “http://www.google.com


#14

@NateHack3r If youre using iceweasel, you can “shell” : "iceweasel"
then once your firefox browser loads,upon selecting the icon, it will redirect to your assigned home page. The home page is done within the options menu of your browser, so there is no need for www.google.com.


#15

Have you tried to launch something like Iceweasel? What would you type in place of “surf”?


#16

@midheaventech I tried replacing “surf” with “iceweasel” and when I click on it nothing happens, am I missing something.


#17

I just tried it out and it worked on mine. It takes 30+ seconds to load after the icon is selected, but there was a loading screen. Did you rebooted your pocketchip after you saved the changes to the config.json file? I also think you can run iceweasel from the terminal by typing iceweasel or firefox and returning the line. Try typing iceweasel in your terminal and see if the package runs at all or what it says and let me know.


#18

It is also strange, because even after i purge iceweasel. Something is left over because using firefox still loads the browser. I checked for files and packages and try purging firefox , but it says there’s nothing there.


#19

**Frozen PocketCHIP fix without reflashing**

Hi everyone,

So a lot of people are customizing their PocketCHIPS GUI; awesome! Well trying their best. Sometimes you succeed and sometimes you forgot a {curly brace}, and your PocketCHIP won’t load after rebooting or gets hung up on the splash screen.

Never fear your serial connection is still here!

1.Turn on PocketCHIP and plug it into your computers USB port(on the newer macsbookpros I’m pretty sure you will have to use a hub that supports USB 2.0)

  1. In terminal on your desktop computer type ls /dev/tty* and you should see a list of serial connections

  2. You should see /dev/tty.usbmodem1d111 on that list. If that is not on your list and you do not know which one is your PocketCHIP simply run the command from step 1 without PocketCHIP plugged in, and then run is again with it turned on and plugged in. What ever shows up that was not there before is most likely your PocketCHIP.

I suggest making your terminal session full screen from here

  1. type in terminal screen /dev/tty.modem1d111
    (or screen /dev/tty.whatevershowedup) then hit return
    it should follow with a prompt for 'chip login:'
    First enter the username default i.e chip
    then the password chip, then you are in your PocketCHIP’s terminal shell. I think you got it from here. Change, or fix what ever it is you are doing, save, and exit or reboot your way outta there.

Here is more info on "Connecting to CHIP using a serial terminal"
http://docs.getchip.com/chip.html#headless-chip

This little trick may not work all the time, but its worth a try, and saves your system from being “neuralyzed” by “the flashy thing”.:sunglasses:

If you by chance completely messed up (lets say your config.json file) and didn’t save a backup, here is a copy. Just copy and paste it from your browser to your serial terminal session via the keyboard(ctrl c/ctrl v) and save and that should fix it.

{
  "defaultPage": "Apps",
  "pages": [
    {
      "name": "Apps",
      "items": [
        
    {
      "name": "Terminal",
          "icon": "appIcons/terminal.png",
          "shell": "vala-terminal -fs 8 -g 20 20"
        },
        {
          "name": "Play PICO-8",
          "icon": "appIcons/pico8.png",
          "shell": "pico8"
        },
        {
          "name": "Make Music",
          "icon": "appIcons/musicsequencer.png",
          "shell": "sunvox"
        },
        {
          "name": "Get Help",
          "icon": "appIcons/help.png",
          "shell": "surf /usr/share/pocketchip-localdoc/index.html"
        },
        {
          "name": "Write",
          "icon": "appIcons/texteditor.png",
          "shell": "leafpad"
        },
        {
          "name": "Browse Files",
          "icon": "appIcons/filebrowser.png",
          "shell": "pcmanfm"
        }
      ],
      "cornerButtons": [
        {
          "location": "TopLeft",
          "name": "Battery",
          "icon": "battery_0.png"
        },
        {
          "location": "TopRight",
          "name": "WiFi",
          "icon": "wifiOff.png"
        },
        {
          "location": "BottomLeft",
          "name": "Power",
          "icon": "powerIcon.png"
        },
        {
          "location": "BottomRight",
          "name": "Settings",
          "icon": "settingsIcon.png"
        }
      ]
    },
    {
      "name": "Settings"
    },
    {
      "name": "Power"
    },
    {
      "name": "WiFi"
    },
    {
      "name": "Battery"
    }
  ],
  "background": "0000FF"
}

Also if you just want PocketCHIP or CHIP to boot straight into the console on startup try this.
http://docs.getchip.com/chip.html#boot-into-console
Once you are logged in you can always type startx if you want to run the GUI.


Can PocketC.H.I.P. land me a job?
How to launch Terminal if config.json shell goes to wrong program
#20

**PocketCHIP Classic Styled Desktop**

This one is pretty easy and you don’t have to install anything.

  1. sudo systemctl set-default multi-user.target
    This makes it so PocketCHIP boots straight into a console.
    More info here http://docs.getchip.com/chip.html#boot-into-console

  2. reboot PocketCHIP.

  3. When prompted with

    Debian GNU/Linux 8 ttyl
    chip login:

Login with

chip login: root
Password:chip

  1. Type
    startx&

and there is your awesome desktop.
Utilizing a desktop mouse here may come in very handy, but it is up to you.

you can change to an xfce style desktop by going to
start menu>Debian>Applications>File Management>xfdesktop.
You can utilize the ctrl button with numbers or letters as shortcuts to change the icon format or content’s sizes i.e ctrl + / ctrl -.

Just keep in mind that you are logged in as the root user and if you have not done so you should change your password with the bash command passwd in a terminal session.
Also, use useradd to create a new user(other than chip or root). The new user should be able to login to the awesome desktop the same way, and it keeps you from being logged in as root. Root is a powerful user and it can make or break your OS or worse so tread lightly as the root user.

One more thing your battery status is not shown here, and at the moment I do not know if you will get any kind of indicator if your are too low on power, you could check via the terminal by typing battery.sh or cat /usr/lib/pocketchip-batt/voltage and hitting enter(return), but I would just keep it plugged in.


#21

Thanks for the tips, keep 'em coming! See below for my current desktop. For the Mac users, it’s just as easy to edit your desktop picture through OSX’s Preview app, it has the ability to crop and save as png.

Chief


#22

I want to change my window theme so I can see the tool-bar icons better on the default terminal window and file manager (file browser). Notice in this picture they are invisible, dark icons on dark header-bar. If I were using a main-stream Debian desktop I would look under a system-preferences menu for an appearance utility, but I’m not sure what those utilities are called. I received my pocket chip yesterday :slight_smile: and installed Synaptic package manager. It’s too big for the screen, but I have made it work. It accesses the Debian repositories easily and safely (first reload, then mark what you want to install, then apply, It is like an “app store”. I’ve successfully installed a few favorite programs, but now I want to change that icon theme. Any suggestions?


#23

Hi,
Unfortunately, I do not know how to change the tool bar icons or window layouts in vala-terminal, but I think it is mimicking a system wide theme. I stumbled across is about two weeks ago and by chance changed the window theme, but it switched back afterward. If I can reproduce it i will post it on here.

UPDATE: you could try sudo apt-get install lxappearance
and run it by typing lxappearance
I’m working on making the window smaller so ‘Apply’ can be selected.

UPDATE: Got it !!!

So I was not able to resize lxappearance , but it did come in useful and it probably will for you also.

However, there is some other things you could do. If you haven’t already you could
sudo apt-get install aptitude
It is a GUI to the default (APT)Advanced Package Tool
Once you have it installed type aptitude
Doing a search in Aptitude is equivilent to typing
apt-cache search (insert-package-name) in terminal.

Also, there is a xfce4-terminal already installed and you could run it from vala-terminal, but the edit>preferences menu is over sized for the screen .

You could use Aptitude or sudo apt-get install lxterminal
and running it by typing lxterminal
which seems to work nicely.

let me know what you think, if there is something you don’t like and you want to remove it and its packages you can always sudo apt-get purge (installedpackagename)


#24

**Changing the theme **



  1. sudo apt-get install lxappearance
    (not necessary, if you know where/what the names of the theme name/icon theme names are and what they look like.)

  2. Type in terminal lxappearance
    (the window is to large to 'Apply" the theme, but the idea here is to see what is available.)
    I chose ‘Crux’ for the theme, and ‘Tango’ for the Icon theme.

  3. open a new terminal window and you should by default be in ~/home/chip and ls -a(list all) .
    You are looking for a file named .gtkrc-2.0

4.sudo nano .gtkrc-2.0
Once in it should look like this


You will want to change what is in the parenthesis in
**gtk-theme-name=“Chip”**and gtk-icon-theme-name="Faenza-Dark"
to what you have selected from lxappearance’s “Widget name” and “Icon theme” sections.

Notice you can just comment out the original line with the (#) symbol and type your new one above it.( as pictured )
5. push Ctrl and X at the same time, then save (Y), then enter to keep the same file name.

Then ReBoot!