PLEASE VOTE - CHIP Production Units - How Many Stars?


#21

5 stars. Has been booted (mostly idle) for at least an hour now. No issues. Connected keyboard, composite tv, mouse, wifi, etc. Hoping for CylonJS support soon to play with some automation features.


#22

For me is 5 stars: I love it and works as advertised.

C.H.I.P. arrived few days ago: I did not attach it to the tv as it was being used, so I connected via serial port feature of the micro usb port to communicate with C.H.I.P, configure the wifi (so I could ssh into it) and install the vnc4server (so I could connect via VNC).

So far I did the following:

1- Installed SDK with no issues, but did not try to flash C.H.I.P as everything is working fine for now :slightly_smiling:
2- Sound is OK: I actually like it from the headsets: not tried video (waiting for TV to be free :slightly_smiling:)
3- Up&running for 24+ hours, VNC stable and never crashed.

Few hiccups on the software side:

a) Locale issues, it fails back to C locale (bug?)
b) ChippyRuxpin not starting although i did follow the instructions to set it up (it’s just me?)
d) Not enough power to add a 8gb usb storage stick via the USB port: will try with a smaller one but I believe this is OK

I am looking forward to examples on how to use the GPIOs for IoT projects: I am currently using Arduino board for prototyping but C.H.I.P. has more potential (and is cheaper…)

Keep the good work!

DevDom


#23

4.5 stars.

When I first tried to boot it, it would shut itself off about one second after I pressed the power button. I used a different cable and it worked fine after that.

While it doesn’t matter for my intended uses, the single mounting hole is an obvious deficiency that would make mounting it upright more difficult than it otherwise would be. There are ways around it such as bracket fabrication or using GPIOs as mounts, but those are comparatively ugly solutions.

Connected it to an old black and white Sony Watchman via an RF modulator and a couple of adapters to get the coaxial signal into the 3.5mm antenna jack. Video signal is good enough that I can read text in a terminal fairly easily. Sound quality seems to be fairly decent, but I haven’t tried my headphones. Just the Watchman’s built-in speaker. Had it plugged into a newer Samsung HDTV for a few minutes to show off to family, and one person actually commented on how nice the picture looked.

I’ve made a couple changes under the hood and used it to compile at least three or four kernels for another ARM SBC I own. CHIP has performed as well as can be expected. No crashes. It’s about 20 times slower than my desktop with an AMD Athlon X4 750k, but performance per dollar is actually better.

chip@chip:~/linux/linux-4.4-rc7$ time make zImage
[...]
  OBJCOPY arch/arm/boot/zImage
  Kernel: arch/arm/boot/zImage is ready

real    109m10.004s
user    97m40.240s
sys     7m35.060s
chip@chip:~/linux/linux-4.4-rc7$ ls -lh arch/arm/boot/zImage
-rwxr-xr-x 1 chip chip 4.9M Dec 31 21:17 arch/arm/boot/zImage

#24

I would give it 4.5 stars. It did exactly the thing I wanted (documented on the BBS here). I’d give it 5 but the wait before reboot is mildly annoying. The initial setup was a high current switching power supply that has 6 USB connections for power, a USB hub (not powered) with a keyboard and mouse and a Westinghouse LCD TV for the display. At one time I had a USB flash drive plugged in to the hub also and it worked. I have to say that the composite video display with this TV/monitor was very good. The GUI was very clear and useable. Final deployment of my application was with a 1 A USB power adapter and a self powered USB disk running headless (using VNC for administration). I put the board in a plastic box with one side cut out so the connectors would stick out. You can see the end of it in my avatar.
J.


#25

4 stars. Booted and worked fine out of the box. I’m able to flash buildroot and Debian, but trying to flash CHIP OS fails. Fortunately, I have no interest in running a gui on CHIP, so I’ll stick with the Debian flash.

I’ve kept mine running for hours without heat problems. But I do keep the house temperature low (64 F).


#26

4.5 stars.

I’ve only had it running for a few hours, but it seems to be stable - no crashing, no reboots. Comments:

  • I was unable to get a powered USB hub to supply power for the C.H.I.P. itself. Every time I tried, the C.H.I.P. powered itself off after anywhere from 2-30 seconds. So the only way I could get a wired mouse and keyboard attached was to use a powered hub for the mouse and keyboard and a separate power wall wart to supply power to the C.H.I.P. itself. It should really be able to be powered from a powered hub. Anybody else had any success? I also tried an unpowered hub for the keyboard and mouse, with the same results. Too much power draw?

  • I wasn’t initially aware of the ability to plug into the USB port of another computer an use “screen /dev/ttyACM0” to communicate with the C.H.I.P. - it would have saved me time. Learned about it from this forum post (much thanks NinjaKun!).

  • Went through some pains configuring networking as a headless system. Found out about using the “psk=” option in /etc/NetworkManager/system-connections, which solved that issue.

So now I’m letting it burn in while trying to come up with a good use for it. I have a USB power meter on it, and it’s pulling about what NextThing says it should - about 1.5 watts while idle, and around 2.5 when booting. Cool!


#27

4.5 stars, I had trouble keeping CHIP to stay on while using Ice Weasel. I’d suggest maybe pairing a lower resource browser. I finally got it to run by quickly canceling the page from loading then was finally able to do some google searching.


#28

Will the C.H.I.Ps from the pre-order (getchip.com) be the same as the production C.H.I.Ps now or will they be different?


#29

4 stars,
i like the battery port. With a battery connected the chip works fine, even with a weak/bad power supply. (Too bad that it crashes without battery)

I like the WiFi very much! Build in WiFi is what the iot needs. Big plus.

Internal storage is nice, but I also like the ability to swap SD cards on my pi… But it saves a few $$ so its a plus

I have some heat issues, that’s too bad but I got use to them still a minus.

Software wise I’m missing uvc support and a gpio library but I think both will be included at some point. Everything else worked pretty good. I guess people are just used to full blown Ubuntu or long developed raspbian … But hey, give ntc a little more time!

The label on the header are freaking awesome. I really really like them!!

And never forget, 9! … I repeat 9 dollar!
Jkw


#30

5 stars

Really happy with my C.H.I.P, the WiFi and Bluetooth are working great - haven’t had to flash it. I’m actually trying it out as a headless server for IoT applications. Seems to run Flask over Python great, I can manipulate the WiFi and Bluetooth from Python with it. Had to SSH over serial for first run with Putty which was easy, now I can SSH in using MINGW.

Sad to hear that there have been some issues, I hope it’s just teething problems with production as I think this is a really great product. It will make an exceptionally cheap IoT sensor for higher level developers. I’ll be keeping an eye on it’s stability in the coming days/weeks.

Only downside is that I’d like to see some documentation! Or, I’m not sure where it is hiding…

Thanks for the hard work guys!


#31

Score: 3 - So far. When I first powered it up, it didn’t operate in Adhoc mode meaning I couldn’t connect to it remotely from the get-go. This meant having to mess around trying to find a mouse and keyboard - having only one USB port, I tried daisy chaining my razor keyboard and mouse but the board couldn’t supply enough juice to power both. Additionally, using just the keyboard, some screens on the wireless setup wouldn’t react to tabbing or ‘alt’ hotkeys preventing me from saving my wireless config. It then took me 2 powered USB hubs before I could get both a keyboard and mouse working.

Once I got those going, getting wireless DHCP on my network going was a breeze and with a little bit of tweaking, I now have it running in headless mode with an X server running on my MS Surface tablet - I can turn on the CHIP (I am powering it with a Zerolemon solar battery), SSH into it and kick off an X session if necessary. Now that I have all of that configured, I am very happy with it. I have not yet attempted to use any of the GPIO aspects of it yet.

I do feel that either using X directly off the board or remotely over SSH, the performance (especially when web browsing) is relatively poor. Buuuut, for $9 (and having not used a R-PI or Arduino before, I’m not sure what to expect?), I’ll hold any bashing for now :wink:

TL;DR why the 3? I feel like the setup (OOTB) experience could be better. I think the system should start in adhoc mode from the get-go so it can be remotely configured. Secondly I haven’t used the GPIO components yet so I am holding back on the rating until I get the chance to play with that aspect.


#32

5/5 So far. Both of my C.H.I.P.s booted up with no issues and have each run 10+ hours with no problem. Granted most of that has been fairly low stress, but I have done a few builds on one of them and it handled them like a champ. Quite pleased with them thus far.


#33

5 stars worked right out of the box as it should.
Im just disappointed in the performance.
I planned on making a retro gaming device but its not powerful enough to even run nes smooth.


#34

4/4.5 Stars

Feels well built, worked straight out of the box and no problems with overheating so far! Very impressed with the USB serial connection, very handy! Wifi has been reliable so far and I am broadcasting as a bluetooth beacon from the built in chip without incident.

Was slightly disappointed to get reboots when trying to use a standard mouse and keyboard on a pretty standard Samsung 1A phone charger (was fine powering just mouse). Worked fine with mouse and keyboard when I found my old pihut 2A power supply rather than just the first phone charger in sight. Only other slight criticism would maybe be that the docs can be tricky to find between the different ntc sites and getchip etc.

Looking forward to playing with the battery port.


#35

4.5 Stars
Out of the box it runs, the only issue is that it shuts if its not powered enough to run everything, other than that its worked great. Its been running a week now with no problems. I have bluetooth streaming audio and can ssh into it no problem. I want to flash a headless version, but so far this is an impressive box for $9


#36

0 Stars, because it won’t boot. Flashed non-GUI Debian; no help.
If it booted, 5 stars all the way, but…

News: got it reflashed (had to use a Ubuntu box) and now it works perfectly. 5 stars! Useful and fast, for 9 bucks.


#37

I think it’s a little too soon to tell, since I haven’t left it running for a long time doing anything intensive yet. But no HW issues so far, so if I had to give an answer now, then 5 stars.

Since there are a lot of people having problems, can we create a new sub-category (alongside Kernel Hackers) where all requests for help/support go? I would love to help people out. Maybe an IRC channel or something too?


#38

Ran several days straight connected via USB to Mac and using ssh over wifi. Various software installs and reinstalls.

5 stars so far


#39

I received mine a few days ago. Initially, I couldn’t get it to boot. (at least I didn’t think so) I plugged it into an apple usb keyboard, power, and the video/audio cable from the box along with a microusb cable to my ubuntu pc. The serial interface that was supposed to come up along with the power interface was nowhere to be found on mac os, windows, or linux.

I scrounged around to find an arduino, which can be used as a uart interface, if you jump the reset pin to ground. Then, I was able to see the serial output which showed me that the thing was booting, but rebooted when the kernel loaded usb. Unplugging the apple keyboard allowed it to boot. This may have simply been a power issue, but I haven’t tested it to find out.

The flashing procedure is relatively straightforward, though it seems to only be effective with the fastboot option.

I think there are several categories for ratings here, so I will run down the list.

Expectations management
4/5
Delivery expectations were met. The booting process and the out of the box experience was a little tenuous, but I think very good.

Design
5/5
This thing looks and works great. its a full system with just about all the open sourced io you could want.

Documentation
4.9/5
The quickstart/intro docs are nicely written and quite thorough. It would be nice if it was easier to add to like a wiki. Being an open source design, this might be really good, or just time consuming nextthing and counter productive for the community.

Community support
4/5
Its early days, so this community will develop and probably wind up being active and productive. It does seem that there may be need for some full tome moderators.

Value
6/5
Seriously. Its the future folks. This thing is a super computer compared to what 2500 could buy you in 1985.


#40

1 Star
CHIP has some serious reliability issues. Tried a genuine Apple iphone charger and a high quality 2 amp power supply but still having trouble getting it to boot every time. Booting with a keyboard connected to the USB is completely out of the question. Just won’t happen. Using a powered USB hub I can get it to boot about 50/50. Most reliable seems to be letting it boot fully into the OS with no USB connection and then attaching the hub after it’s booted but still no dice sometimes.

The math just doesn’t add up. The documentation states CHIP draws 300mA peak so even if it’s pushing 500mA out the USB, that’s still only 800mA total current. 1 amp should easily cover that so why am I still having issues with a 2 amp supply? Just theorizing, but perhaps the microUSB is only able to draw 500mA which only covers operation of the CHIP. Yet even when using a powered hub which shouldn’t draw any power from CHIP, it still doesn’t reliably boot.

Another issue that has popped up tangentially, it seems to lose composite video after a reboot. Rebooting from the command line seems to work fine but clicking reboot within the GUI consistently drops the video output. The two lights remain lit so I’m not sure what state the computer is in but there is absolutely no composite video.

In all, I can’t trust something that randomly shuts down. And I can’t use a computer that I don’t trust. Even $9 is too much for something this useless.