Pocket CHIP also does Retroarch


#85

Hey Guys, so I’ve tried everything to get sound working on my Retroarch’ed Pocketchip. Alsa, Alsathreader, Pulse, sdl2, nothing seems to output sound to the 3.5mm jack. Any ideas?


#86

There is an error that occasionally occurres which locks out the sound, the only fix is to reflash, sorry.

It has happened to me once so I feel your pain.


#87

Any way to debug this? A sound works in other places.

And a reflash is not heartache. My config and build are auto.


#88

That I’m not sure, @Jalonzpa and others have tried to figure it out I tried several things and all that helped was reflash, I seem to recall someone saying it was locked into some other process that wouldn’t release it or something.


#89

So wouldn’t a trace of the mixer tell us which process had a the lock on the resource so it could be killed, or better yet, forced into a release and re-take with a mixer?


#90

Probably, I know there is a lot of discussion in the Alsa mixer thread.


#91

Can you link me that thread?


#92

Just did a search for “stutter alsa”…here you go.


#93

Hey guys, could you please test out the Retroarch flatpack for me? The matter is that the time when it was released and I installed it in my Pocket Chip I had also installed packages like docker that I think that slow down the chip and when I tried to launch the flatpak it was sloooow as hell. If it neither works with a fresh flashed chip, we at least have another option to install Retroarch once NTC release in the future the chip’s video drivers.


#94

Gave flatpat a try and it seems to have just crashed the chip.


#95

whenever i start a game on retroarch,it doesnt start up but instead puts "failed to open libretro"
on top of that, i compared my cores to WMG’s and i dont have mednafen


#96

Once I’ve added an emulator to a core, how do I start playing a game?


#97

Having issues installing RetoArch. I followed @WMG instructions and hit a wall with this result:

LD retroarch
obj-unix/release/gfx/drivers_context/wayland_ctx.o: In function gfx_ctx_wl_dest roy_resources': wayland_ctx.c:(.text+0x678): undefined reference towl_egl_window_destroy’
obj-unix/release/gfx/drivers_context/wayland_ctx.o: In function gfx_ctx_wl_set_ resize': wayland_ctx.c:(.text+0x80c): undefined reference towl_egl_window_resize’
obj-unix/release/gfx/drivers_context/wayland_ctx.o: In function gfx_ctx_wl_dest roy': wayland_ctx.c:(.text+0xe64): undefined reference towl_egl_window_destroy’
obj-unix/release/gfx/drivers_context/wayland_ctx.o: In function gfx_ctx_wl_set_ video_mode': wayland_ctx.c:(.text+0x118c): undefined reference towl_egl_window_create’
collect2: error: ld returned 1 exit status
Makefile:187: recipe for target ‘retroarch’ failed
make: *** [retroarch] Error 1


#98

Same for me and other users. I know that there were compiling issues on arm a while ago, but is was even before the launch of c.h.i.p., so I infer that it could be a dependency problem or so because NTC repositories aren’t online. I’m waiting until somebody come out with a way to boot our c.h.i.p.s off usb with an updated distro and try it again.


#99

Just visiting this forum, surprised found out that NTC is dead. What a bummer.

Despite all its flaws and the major flaw that turns me off… with further polish on the OS it could be a cool device but some guy found the solution already.

I gave it another try, attempted to install RetroArch from Pocketinstaller, but I got the errors as well.

Any other solution? Or at least I remember some guy had Mednafen works with GUI but I can’t find the link anymore.


#100

I gave up with RetroArch, the thread you’re thinking about is Mednafen (Emulator) configuration (GBC/GBA/SNES/NES) I’ve just used this and had no issues, the GUI script is added at the bottom of the OP and works pretty well.


#101

Thank youuuuuuu sirrr!!!


#102

Can’t compile the last version. Tried v1.7.0 from over here https://github.com/libretro/RetroArch/releases and it worked as in the video.


#103

I install v1.7.0 with the following commands. But cores are missing, is there a solution for this?

sudo apt-get libasound2-dev cmake build-essential git pkg-config
git clone git://github.com/libretro/RetroArch.git
cd RetroArch
git checkout v1.7.0
./configure --enable-opengles --disable-oss --disable-sdl --disable-ffmpeg --disable-vg --disable-cg --enable-neon --enable-floathard
sudo make


#104

Try these ones