PocketCHIP running CHIP 4.4 GUI


#5

Very nice, the launcher is ok, and you get pico, but the portable full on computer is the reason for the season


#6

Hear, hear! I hope this is what NTC is working towards. One ring to rule them all.


#7

Ah, I’m not the only one with these problems. I ran into the same inversed touchscreen problem and managed to calibrate my screen so it worked perfectly.

I’ve been trying all day to “zoom out” and make everything twice as small so that I can simply use my OS. Most menu’s fall outside of the screen and there’s no way to save or edit a lot of stuff.

I’ve been trying to mess with the xorg.conf file in /etc/X11/ but it’s been of no use yet. The “display” menu in settings has some options to switch screenratio, but any changes don’t seem to be saved.

I’ve also played around with xrandr but that only made the area outside the screen even bigger.

Anyone else know a way to emulate a bigger resolution so that everything is smaller?


#8

A virtual machine, perhaps?


#9

This thread on stackexchange discusses a few possible solutions to scaling the resolution. Specifically it sounds like xrandr should be able to do what you’re suggesting - have you tried the --scale option already?


#10

Thank you for the link, sadly it yielded results, but not what was needed. :c

Screen goes black. It appears that the system is still functional, as pressing the “Home” button to bring up the power menu, then tapping around where the “restart” is on screen works no problem. Restarting causes the system to default back to its original scale - regardless of its scale pre-restart.

Going larger causes the screen to flicker, then immediately kicking back with a slightly larger screen, however producing this error.

chip@chip:~$ xrandr --output None-0 --scale 1.1x1.1 X Error of failed request: BadValue (integer parameter out of range for operation) Major opcode of failed request: 140 (RANDR) Minot opcode of failed request: 26 (RRSetCrtcTransform) Value in failed request: 0x3f Serial number of failed request: 24 Current serial number in output stream: 25

So, this works in making the screen bigger, but does not work in shrinking the screen… Poo.

…Though, setting the screen back to 1x1 gives the same error, sets the screen back to 1:1 scale. Not sure how relevant the error is, then.

Sadly, also updating the lightdm.conf with the line from above does nothing, also.


Make the Debian GUI smaller
#11

Forgive my naivete, but is None-0 the correct name for the output device?

Oh well, I was hopeful this was the solution. I’m definitely looking
forward to a more usable GUI on the pocketchip.


#12

It is, at least to my knowledge.

Here’s what running just “xrandr” shows.

Screen 0: minimum 320 x 200, current 480 x 272, maximum 8192 x 819 2 None-0 connected 480x272+0+0 0mm x 0mm 480x272 59.52* Composite-0 connected NTSC10 72.01 + NTSC 59.94 + PAL 50.00 PAL5 54.71 PAL10 60.13 NTSC5 65.56 PAL15 66.38 NTSC15 79.47


Make the Debian GUI smaller
#13

@BladeMaverick Try looking in
/etc/X11/app-defaults
Maybe “xvidtune” if you type that into terminal, you get some resolution settings.


#14

Stupidhead here has been flashing all day and this looks really nice.
A little tweaking and I think it will be very usable. One of the keys would be if one could keep the typeface large and then scroll around the field to what interests one. Kurt Woweeeeee!!!


#15

Actually using a larger virtual display area might be the go.


#16

Is pico 8 in 4.4?


#17

Ok,

I found out I had to use an Rf mouse so I could get the arrow to scroll around.
A wired USB one would do it too. Get Bluetooth to pair and attach a B/T mouse.
I changed the typefont from 10 to 8 and will look at whatever configuring a
larger virtual display is. I like it so far.
Kurt


#18

Pico8 is bundled with pocketCHIP which is still 4.3, so no, not in 4.4.


#19

I am SO doing this tonight when I get home from work!

Was already going to re-flash my PocketCHIP CHIP…

I might grab a tarball of PocketCHIP “/” onto my NAS - see if I can get Pico-8 running on 4.4… I already did a find and tar of everything with “pico” in the name…

I already paid for the whole Pico-8 and Voxatron everywhere deal - but someone here said the RasbPI pico-8 doesn’t work on CHIP.


#20

I just bought the all versions Pico8 I’ll give that and vox a try later.


#21

Done - this is heaps HEAPS better than PocketCHIP UI!

few things need tweaking…

What it really needs? Autohide top bar, and an autohide dock (like PLANK!) at the bottom - with Conky displaying stats like time wifi signal, battery etc… that’s what I’ll be working on doing anyway…

Terminal seems to extend below the bottom of the screen which is a real PITA!

I didn’t end up running calibration - I just used @BladeMaverick’s xorg.conf settings above and it worked!

Looks like I may not be selling my PocketCHIP chassis after all!


#22

I usually just maximize the terminal, it then fits the PocketChip screen. You can also press the ALT button and move the window around to get the portion you need.


#23

I installed guake and that’s much more usable on pocketship than xfc4-terminal…


#24

@UnixOutlaw is guake a terminal that gives you a drop down window like well…quake? I use a diffrent one but I sirely love it. Also I guess I’m not buying your pocket chip now! haha let us know you get things running better. I only saw on screenshot but it will be great to have alot of options when it comes to GUI when I get my hands on a poketchip