PocketInstaller (v5.0)


#53

@BigBadHodad it doesn’t install pcsx, if I have time can try to add it before next release. It takes a little time to add systems, though, as I have to test them all before. Regarding to the existing systems, will be kept, for sure.

@Chipox I thing I know what is going on… can you see a picture when you execute it or just a flask with a liquid? I have been aware that paths work when executing from the icon, not when executing from terminal though. I will try to fix it, however I can get them working from terminal or from the icon, not both at the same time which is not good.

If you have Pocket Home installed what you can do by know is gear icon on the bottom right side of the screen -> Advanced settings -> Personalize your home homepage -> Icon management add. You can choose the icon “desktop icon” in your PocketInstaller folder, as a command choose vala-terminal -fs 8 -g 20 20 -e ~/PocketInstaller/PocketInstaller.sh

Run PocketInstaller from your desktop icon. Thank you for your report, I will work hard to have it fixed. Sorry for the inconvenience caused.

Edit

The problem was caused due to the fact that when running from desktop, complete path was needed as the working directory was not ~PocketInstaller. In order to fix that, cd ~/PocketInstaller has been added at the beggining of the script and works for me both ./PocketInstaller.sh or launching it from the desktop.

I suggest you @Chipox to launch it from the desktop icon as I told you before and in the future release it will be solved. Sorry for all the inconvenience caused.

Cheers,

Iker.


#54

@Iker You’re right, I tried to execute from the terminal at first.
And when executed it I saw a flask with a green liquid.

So I’ve just followed all your steps to create the PocketInstaller desktop icon from the PocketChip Homepage with success.

I then ran PocketInstaller from its icon and this time the picture of the box with colored avatars was displayed as a picture instead of the previous flask.
I ticked all checkboxes and all automatic tasks were processing accordingly for several minutes.
Afterwards, the PocketChip came back directly on its Home.
I ran again the PocketInstaller icon and this time the picture displayed with one remaining checkbox only, the Vice one (and yet I previously ticked it)

I made several attempts to make it install in vain.
I succeeded to make a picture of what happened in the terminal and see below some extracts of what was displayed on the terminal screen:

selected: vice(C64,C128)…

vice is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
converted ‘http://www.zimmers.net/anonftp/pub/cbm/
…----2016-11-19 23:19:58-- http://zimmers.net/anonftp/.../VICE/old/vice-1.5-roms.tar.gz
resolving www.zimmers.net(www.zimmers.net)…
wget: unable to resolve host address ‘www.zimmers.net
gzip: stdin: unexpected end of file
tar: child returned status 1
tar: error is not recoverable: existing now
[sudo] password for chip: so I typed it + enter
several same displayed occured then:
’/tmsp/vice-1.5-roms/data/PET/edit4b40’ ->’/usr/lib/vice/PET/…

…/kernel1’ -> ‘…
…/kernel2’ -> ‘…
…/kernel3’ -> ‘…
…/kernel4’ -> ‘…
…/vIC20/basic’ -> ‘…
…/vIC20/chargen’ -> ‘…
…/vIC20/kernel’ -> '…
Closing PocketInstaller, see you soon!

So I guess something is wrong with VICE installation only, isn’t it?

Besides what about Megnafen for instance, how can I make it run and from where please so that start to install roms and play with them?
The same for Doom?
And regarding OpenTTD, DOSbox, and ScrummVM, I don’t have a clue of what can be done with them…

Thanks a lot


#55

Hi,

Thank you for reporting all the bugs, is being so useful. Actually I don’t have VICE installed that’s why I didn’t know it wasn’t working. However @Dmian the coauthor of this (also known for creating the incredible artwork and translating my instructions to an actually understandable language :laughing:) reported it to me a few days ago.

I’ve just solved it and also got the configuration file so it will automatically be parsed after the installation. Could you wait for next release for VICE? It should be soon.

Regarding to the other systems I believe it would be greate if I created a guide. Let’s try something

cd /home/chip/.mednafen
ls -l

Write down the name of the *.cfg file you find there.

sudo cp -R ~/PocketInstaller/Configuration/mednafen.cfg thenameofthefile.cfg

Now you should have the correct configuration with the keys mapped.

mkdir roms

Afer that if you want to create roms for each system you can:

mkdir ./roms/nameofhtesystem (gba, gb…)

Copy the roms into the respective folders with a USB or anyway you like.

sudo cp -R ~/PocketInstaller/Launchers/mednafront.sh /home/chip/mednafront.sh
sudo cp -R ~/PocketInstaller/Launchers/scummvm.sh /home/chip/scummvm.sh

Now just create icons with these commands:

Mednafen: ./mednafront.sh
ScummVM: ./scummvm.sh
Doom: prboom
DosBox: dosbox

Launcher for OpenTTD will be added next release. If you want it now:

sudo nano /home/chip/openttd.sh
openttd
Control +x to save, yes.

Create this icon:

./openttd.sh

Cheers,

Iker.


#56

Hello,

You’re welcome. I think I have a lot of luck to find so helpful community and be able to improve my knowledge so that go ahead farther with my PocketChip.

Of course I’ll wait for the new release for VICE :wink:

Agree with you for the guide which would help to understand everything for less advanced people like me.

So, regarding the first attempt
cd /home/chip/.mednafen

Unfortunately could not find this directory.
Actually before installing PocketInstaller and run it, I’ve NOT installed Mednafen yet as I believed that by clicking on the associated checkbox it would proceed with it.

Did I miss something please?
Was I really supposed to find the *.cfg file in a .mednafen directory after the PocketInstaller execution from the associated icon created yesterday from PocketHome?

However I found without any problem the mednafen.cfg under the ~/PocketInstaller/Configuration directory.
I also found mednafront.sh and scummvm.sh into the Launchers directory

But could NOT find both prboom and dosbox
indeed after running the command find ~ -name “prboom” for instance, I got no result.

For your information note that my PocketChip has been flashed recently in v4.4 alpha with success to get 3D acceleration.
And nothing else installed except SSH and elinks, git followed by PocketInstaller, xinput-calibrator and PocketHome.

Thanks a lot.


#57

I might be missing something. Did you install mednafen (on your own with PocketInstaller, it doesn’t mean any difference to me)?

Open terminal and just try:
cd .mednafen

If it doesn’t work try
cd PocketInstaller/.mednafen

Regarding to your other doubt, try just writing in terminal:

prboom or dosbox depending on which one you want to run. You shouldn’t find anything, is just the command to run them.

Cheers,

Iker.


#58

Yesterday I selected all checkboxes in PocketInstaller and as you know only VICE check box remain when launching again PocketInstaller from the icon you helped me to set.

I’ve started from the termeinal both prboom and dosbox with success.

Unfortunately, opening terminal and just try:
cd .mednafen
did not work nor:
cd PocketInstaller/.mednafen

I tried to go ahead with my investigation by keeping your above advices in mind and found this on this topic:

So I closed the terminal (CTRL Q) and restarted it and type again directly:
mednafen
some lines were processing (I made a picture of them just in case)
cd .mednafen
IT WORKED!!! :slight_smile:
and then go ahead with your steps listed in your short above guide and could find my mednafen-09x.cfg by listing content of .mednafen directory by ls -l

I wanted to keep you informed of that “discovery” which is a good news actually before going ahead with your guide advice so that you can take care of it in your futur official guide for instance. (even if here, it is not a Mednafen topic of course).

EDIT: everything works fine or almost.
I succeeded to play some roms from GBA, GBC and NES but could not with SNES roms on my PocketChip.
I’m happy except that I cannot get the sound nor get my iBuffalo Classic Pad working with Mednafen while it works fine with PICO-8.


#59

Thank you! Mednafen was probably the first thing I installed following that great thread by @0xicl33n but I forgot that it is needed to run first, it was a few months ago. Your advice will be so helpful for the new version as I didn’t take into account that.

I am glad the emulators are working for you, let’s see Vice in a while :grin:

Cheers,

Iker.


#60

Despite my investigations, when I play a game on Mednafen, I’m still not able to make sound work in my headphone plugged on my PocketChip jack, and yet, it works fine with Pico-8, Doom, etc…

Any idea where to have a look please or how to fix this annoying problem?

Thanks a lot.
Chipox


#61

I think you should ask in the topic about Mednafen, I play without sound so no idea but found this on that topic:

Cheers,

Iker.


#62

Hi,

Thanks @Iker, I will.
Indeed, I don’t know how to apply this sound file change actually.

Cheers,


#63

Hi @Chipox,

As you said you have done some research I supposed you already know how to edit the config file.

Use cd to go to your .mednafen folder.
Locate with ls -l the file with the cfg extension.

sudo nano nameofthefile.cfg

Go down (is just after snes and before vb) you find this line:
sound.device default

Change it to:

sound.device sexyal-literal-default

Control+x and then yes to save.

Cheers,

Iker.


#64

Hi @Iker,

Yep, at first, I could not find the line to modify in the config file by editing my mednafen-09x.cfg file under the directory /home/chip/.mednafen
So I installed VIM on PocketChip, learn the few command so that find the location in the cfg file.
Launched my file edition
VIM mednafen-09x.cfg
Thanks to the command:
/sound.device default
I finally found it in less than a second, but at the 7830th line!!!
modified the line by sound.device sexyal-literal-default instead of sound.device default as adviced
Press escape to delete the INSERT at the bottom of the screen which prevented me from saving and exiting the edition.
And saved and exit by typing the command within the file
:x
Check back by entering again within the file so that see if it was well changed successfully, exit and made a tried on Mednafen.

And it works and it was a very good moment to investigate by myself, keep attention to community advice and learn to use VIM so that make it possible.

Great PocketChip really, fun as well for everybody, installing, configuring, working or playing!!!

Hope it will help any one interested.

Now, I’m looking forward to installing the new PocketInstaller version! :wink:
Thanks @Iker


#65

v3.0 has been ready for some weeks, however we wanted it to be tested correctly before its release and that was delayed due to the fact that we were busy.

We have been thinking that it would be interesting to have some people beta testing some of the releases. Not the minor ones (just new installs, fixes) but the major ones.

Anyone wants to try the new v3.0? We are looking for people that is not afraid of flashing as we want it to be tested using a clean install. Also, people with bigger screens would be a good option.

We just want some feedback by private message (if something failed, any idea, whatever you want).

Cheers,

Iker.


#66

Im tempted to order a spare chip just to use testing stuff if i do ill message you,

Is pcsx part of the install as well?


#67

Sorry @BigBadHodad not included yet. I have seen that it should work on 4.3, what I’m using, I might give it a try but probably not soon.

Anyone who wants to try the new v3.0 will be welcomed even if it’s not a clean install. It would help us a lot!


#68

I just got my 10-pack of alphas, so I have plenty of “fresh meat” to try it out on! Hit me with it, and I’ll give it a shot.


#69

Sounds great. Just sent you a PM.

Thank you!


#70

Tested, didn’t finish the way I would expect - PMed back. (Shall I flash another one to “stock PocketCHIP” while waiting? :stuck_out_tongue:


#71

Hahaha as you already know the main failure was, as always, my lack of explanations. I’ll take care when writing the new How-To.

Thank you for your help, has been so useful. It’s a bit late here, it will be probably released tomorrow!.


#72

We’re almost there!

I think you’re gonna like it! :blush: