SSH using vanilla chromebook over usb?


#1

Has anyone used a chromebook to connect to their freshly flashed headless chip? I’ve tried using Secure Shell, but it keeps timing out. I’m not sure if it’s my methods or tools that are to blame. Any help would be appreciated, it’s probably best to assume I’m pretty incompetent. Thanks!


#2

I haven’t personally, but if you press CTRL-ALT-T, it brings up a thing called crosh (chrome os command line). I’m thinking it should work the same as a Linux machine.


#3

Thanks for the quick response!

Unfortunately, for future readers, crosh no longer supports SSH. I downloaded a tool that it recommends Secure Shell but only got a timeout when trying to use it to connect to the Chip.

I used the target: chip@/dev/ttyACM0 Where ttyACMO was the most likely thing that popped up when I called dmesg (following this post)


#4

To connect to your freshly flashed headless chip you want a USB serial connection not a ssh connection:
Read the section “Control CHIP Using a Serial Terminal”:
https://docs.getchip.com/chip.html#headless-chip

You may also need sudo privileges (https://www.parobalth.org/chip-intro.html) and have to install the program “GNU Screen”. I don’t know if it is installed or can be installed on Chrome OS.
Once you have screen working
Run

screen /dev/ttyACM0

in your terminal (at the command-line) and once the connection is made log in with your username and password.


#5

I agree with @parobalth.
Ssh is wireless, not USB connected, so you have to connect to chip through a USB serial terminal. I think there are some on the chrome web store, and you can always use crosh.

Sorry for the short post, I have to go to school now :yum:


#6

You could try something like this: https://chrome.google.com/webstore/detail/diginow-serial-terminal/kfmecbejcnepbfdcdbbhfcjmdmmcmoah?hl=en


(Solved) Crazy usb0 Getty disconnects, restarts
#7

Thanks to @parobalth @Tacocat4642 and @AllGray for setting me straight!

For anyone who comes after, I ended up using Beagle Term to connect to the chip via my chromebook. It was super easy, and auto-detected my usb connections so I just needed to choose the new one.


Headless console crash, hardware crash: Further evidence of hardware instability
#8

Thanks @def_a_newb for the great find Beagle Term. It works on my Mac, and I assume on all platforms that can run Chrome browser.

After Beagle Term refused to connect on a borrowed Chromebook because of its ChromeOS is incompatible, I attempted to use DigiNow Serial. The latter did work on said Chromebook but it only does 9600bps and there is no way to change. Although there maybe a way to change CHIP’s default baud rate to match, it won’t be an easy job if all you have is a Chromebook and no other way to connect. Beagle Term definitely a better alternative.