The New and Improved Flasher!


#1

Thanks to wonderful work from @howie and @nayru, we’ve released a new and improved Flasher. It has a new look with more details and provides a better flashing experience across operating systems.

Open a new Chrome window and check it out for yourself at flash.getchip.com or flash.getchip.com/pro. Please post any feedback below!

Stay tuned for more updates soon regarding shipping, C.H.I.P. Pro availability, and Gadget!

\ (•◡•) / - everyone at ntc


Flasher Version 5.0.0 - Release Notes

New Look and Feel

  • Flashing progress now appears in a notification window as well as the Flasher page.
  • You can mouse-over to switch between the C.H.I.P. Pro and Dev Kit animations.

Setup Instructions

  • Keeps track of setup for streamlined use.
    
  • Windows driver no longer requires a reboot to install.
    

Flashing

  • Improved OS support for Windows 7 and 10; OSX 10.11 and 10.12.3; and Ubuntu 14.04 and 16.04.
  • Added more detailed instructions, error handling, and failure reporting.
  • Flasher tests for FEL connectivity before starting the process.
    
  • Flasher now verifies Fastboot connectivity on C.H.I.P. and PocketC.H.I.P. images.
    
  • C.H.I.P. Pro skips NAND detection step for faster flashing.
    
  • More detailed error messages with possible causes.
    
  • Faster downloads and flashes thanks to compressed image files.
    

Misc

  • You can download and browse images without plugging in an NTC device.
    
  • Flasher no longer tries to poll for a C.H.I.P. in the background unless user is engaging with it.
    
  • No longer need to stop/restart the web app after errors.
    
  • Version checking ensures the web and chrome app are in sync.

#2

You listened!!!

Thank you NTC!


#3

Great job guys!

As I’ve commented several times, your success (where other SBCs apart from mainly Raspberry Pi failed) is being able to create a strong community and listening to the feedback.

Cheers,

Iker.


#4

I just wondered where you ran off to for so long @dcschelt; I’ve missed your telling us the blog got updated. :slight_smile:

The new flasher looks nice! Will probably test it out on a CPro in the coming days.


#5

I’ve been busy working on something super fun… :zipper_mouth: for now.


My thoughts on the Silence (They're all positive thoughts!)
#6

I found that a reboot was needed on my win10 machine before i could flash. Other than that, it was a great experience, and very appreciated that we can access the image files over at flash.getchip.com/ls


#7

Sweet I’ll try it out asap


#8

Ooh… I’m going to be glued to the blog and the BBS for a while then… I want to see what it is. :joy:

PS, thanks, guys, for listening to everyone. This is a sign of a great company.

And thanks @Howie and @nayru as well.

squeals like a little girl

EEEK! GADGET!


#9

just tried it on an alpha, it gets to resetting to FEL and it tells me it failed and I unplugged it, could it be that NAND problem the alphas had? I cannot recall how to fix that, though it could be my USB port.


#10

Hmm… could be your USB port… although I haven’t tried the new flasher tonight. (I need to use it anyways, I need to reflash my Alpha.) What type of port is it? 2.0? 3.0?


#11

I also look forward to testing this when i get time, thank you for the updated flasher.

A request that has been asked multiple times, can you develop a clone tool. So we can duplicate one chip to another.

Currently i write bash scripts for my setups and re-run it on each unit… this would save some people some time and allow them to clone a old chip they have no idea what they did to the original setup


#12

It’s a 3.0 but I’ve had no trouble with flashing from it before Lenore thrice Stanford once and alpha one once( zordon if the one that won’t flash)


#13

I just tried flashing my Alpha with a 3.0 port, and it didn’t work. It worked first time with a 2.0.


#14

Weird guess some are more groovy with 3.0, guess I’ll look for a 2.0 hub tomorrow


#16

I don’t know if it’ll help, but it might help if it’s powered, depending on your computer.


#17

Flashed my PocketCHIP this morning, ZERO issues! Nice work!!!


#18

Update: one my CHIPs became unresponsive (Toshiba NAND)…

Refused to come up as a gadget - no longer appeared on wifi… Not sure what happened… I’d added a “tiny” 32 GB thumb drive and was copying stuff off it to my NAS when it stopped responding…

Anyway - I flashed it - and the process worked flawlessly! More intuitive than the old interface too…

Up and running again in no time…

I’m not too bothered about losing data - it’s maybe about 15 minutes slogging around in the CLI to get a CHIP up and doing what I need it to do after flashing :

  1. wifi
  2. change hostname and add users and change passwords and update sudoers
  3. update repos, upgrade and install other packages I need

I kinda think of it like cloud servers (e.g. in Amazon AWS) - treat your O/S as disposable and ephemeral - your data should be elsewhere… 15 minutes isn’t too long all things considered - but I guess if I was doing it every 2nd day it would become painful - I guess I need to get off my arse and delve further into provisioning with stuff like ansible…

Anyway - this particular CHIP was previously “genbu”, and I was intending to use it as a sort of pentesting/wifi AP doovilacky, kinda like the USB Armory… So I’now ve got it with a battery, a 16 GB thumb drive, inside a TicTac lolly (Aussie for “candy”) box and then that inside a black sunglasses “bag”… I was thinking of adding a speaker in there - because the whole thing reminded me of those “lame” “laughing bag” gimmick toys that were all the rage in the early 1970s (basically a “device” inside a drawstring bag that when you shook it or squeezed it - it made laughing noises)…


#19

Offtopic, but…, I would definitely recommend learning some sort of automation tool. Ansible is my favourite, although I also know puppet and cfengine.

I should set up some Ansible tasks to configure a CHIP for me, the sorts of things you mentioned… Then I would just need to bring it up on the network and…


#20

I’ve done a fair amount of work with Puppet in the past - including some stuff from scratch (and did the three day course they “offer” [work paid for it] in 2012)… Recently did some work with Ansible (mostly already setup playbooks).

I love the simplicity and serverless methodology of Ansible… Having a Puppet server at home just seems like overkill…


#21

My chip still doesn’t work :confused: