Unable to connect to wifi that requires username & password


#1

So I got my chip today & I tried to play around a bit at the uni. I read a few guides like https://bbs.nextthing.co/t/setting-up-chip-as-a-headless-server-with-minimal-tools/1505 and some google.

Anyway I connected over usb to it and went to use nmtui. It showed all the available wifis but when I chose activate I got hit with something along the lines of “unable to get AP security info”. Using nmcli dev wifi list everything appeared correct.

The wifi at uni requires a username & a password (eduroam). All the tutorials I have seen so far don’t mention username.

Would something like this work? "nmcli dev wifi connect username password "

I wonder if it would be doable with a config under interfaces.d but don’t know the setting for there.

Once I get that down, will be time to try and install debian just cli to it!


#2

Anyone got a good guide for connecting with cli to eduroam? or any wpa-enterprise wifi that requires username & password?

I still haven’t figured it out and managed to break the networking already once --> re-install OS :stuck_out_tongue:


#3

I’m guessing here, but I suspect your wifi network uses WPA2 Enterprise. I believe @UnixOutlaw got it working. See his post here:


#4

Not /etc/interfaces or /etc/interfaces.d

The correct location is :
/etc/NetworkManager/system-connections

If you “handcraft” your own file in that directory - it should have the same file name as the SSID - here’s an example that works with my work’s wifi AP :

[connection]
id=[SSID]
uuid=6e0e1666-8c2f-4d93-866a-b2e8ad957982
type=wifi
permissions=
secondaries=
timestamp=1459329796

[wifi]
mac-address=[your MAC address]
mac-address-blacklist=
mode=infrastructure
seen-bssids=[Not Sure What Needs to Go here - looks like a MAC address or something]
ssid=[SSID Name]

[wifi-security]
group=
key-mgmt=wpa-eap
pairwise=
proto=

[802-1x]
altsubject-matches=
eap=peap;
identity=[DOMAIN\\username]
password=[password in plain text]
phase2-altsubject-matches=
phase2-auth=mschapv2

itentity= field may require your AD domain name then “\” user name (when configuring via the GUI you only need a single backslash) - e.g. EDUROAM\\user.name (note - this BBS requires three backslashes to display two).

Change the SSID name in the config file, username, and MAC address and it should just work.

Also ensure the file has “-rw-------” permissions (0600 - e.g. sudo chmod 0600 [filename]).

I’ve been unable to get Network Manager via the GUI to recognize files in /etc/NetworkManager/system-connections - I guess I could just try restarting NetworkManager - but I just find it easier to reboot CHIP so it reads that file…

If I hadn’t previously taken in a laptop running Ubuntu 15.10 and successfully connected - I may never have gotten it to work - because manually configuring it in the ChipOS/Debian XFCE NetworkManager GUI NEVER seems to work - no matter what options I choose.

Some other values you may have to change in your case are “eap=”, “phase2-auth=” - you could try “leap” for eap (i.e. eap=leap), and perhaps “auto” for phase2-auth (i.e. phase2-auth=auto).


#5

Hey and thanks from the reply from back then :stuck_out_tongue:

Managed to get some more time so I copied the eduroam config from /etc/NetworkManager/system-connections on my laptop changed the mac to the HWaddr of wlan0 from ip a and made sure owner / permission is root:root 600

Rebooted and nothing. the id / ssid is eduroam, as is the wifi named. I didn’t change the uuid though as I had no idea what to put there.

Any suggestions?


#6

Suggestion:

TERM=linux sudo nmtui

Should solve 99.9% of the cases. Need something special, use nm-cli ($ man nm-cli), where $PASSWORD and $SSID are, your password and wifi name:

$ nmcli con add type wifi con-name '$SSID' ifname wlan0 ssid '$SSID'
$ nmcli con modify '$SSID' wifi-sec.key-mgmt wpa-psk
$ nmcli con modify '$SSID' wifi-sec.psk '$PASSWORD'
$ nmcli con up id '$SSID'

#7

nmtui can’t deal with wpa2-enterprise.
Does’t seem like nmcli has a flag for username.


#8

Bump for update. It’s working since some time now. It appears that the reboot(s) weren’t enough but after I shut it down to move it to another usb port, it connected just fine! Or dunno.

Anyway thanks to all the people that commented and especially @UnixOutlaw