Unable to Flash from the SDK


#1

I am receiving an error on running chip-update-firmware.sh from CHIP-tools.

Error: Unable to locate sunxi-fel utility.
Install sunxi-fel with:
CHIP-SDK setup script   [github.com/NextThingCo/CHIP-SDK]

These are the steps I followed:

cd ~
git clone https://github.com/NextThingCo/CHIP-SDK
cd CHIP-SDK
./setup_ubuntu14.04.sh
vagrant up
vagrant ssh
vagrant@vagrant-ubuntu-trusty-32:~$ cd CHIP-tools
vagrant@vagrant-ubuntu-trusty-32:~/CHIP-tools$ ./chip-update-firmware.sh

I am using VirtualBox 5.0.24 on an Ubuntu 14.04 host. I installed Vagrant 1.9.1. I am using the CHIP-SDK most recent commit as of February 11 2017 (3cb072f).

This is the documentation I am following:
https://docs.getchip.com/chip.html#installing-c-h-i-p-sdk

Thanks for you time.


Neither the Web Flasher nor native Ubuntu SDK works on Chip Pro
#2

In looking at how the code is setup inside chip-update-firmware.sh, the CHIP Pro is currently not supported. It appears that @computermouth is out of the office (@gush mentioned this in a Buildroot/WiFi related thread).

I believe there has to be a way to get the command line tools to flash a CPro as there are scripts to build a CPro image and flash it (all done locally and not .chp files)


#3

Also the CHIP-buildroot files do not appear to be set correctly by default in the SDK.

cd ~/CHIP-buildroot
make menuconfig
target options ---> Target Architecture (i386)

This needs to be ARM, not i386. It looks like chippro_defconfig in ~/CHIP-buildroot/configs contains the correct configuration.


#4

sunx-fel is located in ~/sunxi-tools. However, NTC did not set up their vagrant config properly an that dir is not in the user PATH. Add it to your PATH and see if you get any further …

In my case, the chip-update-firmware script was complaining abt not being able to find sunxi-nand-image-builder, and I fixed it by doing the above. However, I still cannot successfully flash my CHIP PRO :rage: … it starts the flashing and looks like U-BOOT gets flashed, but then it fails at the end with:

HTTP request sent, awaiting response... 200 OK
Length: 258736168 (247M) [binary/octet-stream]
Saving to: ‘chip-40000-1000-100.ubi.sparse’

100%[======================================>] 258,736,168  337KB/s   in 13m 5s

2017-02-11 23:54:25 (322 KB/s) - ‘chip-40000-1000-100.ubi.sparse’ saved [258736168/258736168]

Image Name:   flash server
Created:      Sat Feb 11 23:54:25 2017
Image Type:   ARM Linux Script (uncompressed)
Data Size:    1784 Bytes = 1.74 kB = 0.00 MB
Load Address: 00000000
Entry Point:  00000000
Contents:
   Image 0: 1776 Bytes = 1.73 kB = 0.00 MB
waiting for fel...OK
waiting for fastboot................OK
sending 'UBI' (252672 KB)...
FAILED (command write failed (Bad file descriptor))
finished. total time: 0.001s
resuming boot...
FAILED (status malformed (0 bytes))

[SOLVED] Cannot flash dev kit either with web or SDK
#5

@wypoon j̶u̶s̶t̶ ̶a̶ ̶s̶a̶n̶i̶t̶y̶ ̶c̶h̶e̶c̶k̶ ̶b̶u̶t̶ ̶d̶i̶d̶ ̶y̶o̶u̶ ̶h̶o̶l̶d̶ ̶t̶h̶e̶ ̶F̶E̶L̶ ̶b̶u̶t̶t̶o̶n̶ ̶w̶h̶i̶l̶e̶ ̶p̶l̶u̶g̶g̶i̶n̶g̶ ̶i̶n̶?̶ (Edit: Yes of course you did, or you wouldn’t have gotten that far.)

By the way thanks for sharing your fix on the PATH, that solved my problem.


#6

Yeah, you missed the “100% … in 13m 5s” part in my dump :slight_smile: … to have it still not work after waiting that long is exceedingly frustrating!


#7

The SDK with the vagrant virtual machine appears to place symbolic links in /usr/loca/bin for sunxi-fel as well as the other sunxi tools, but the links point to /home/vagrant/, which contains no executables.


#8

I’m back!

Anyways, sorry you’ve gone through all this here @chipper and @wypoon, and thanks for pointing out the problems with the Vagrant set up there, I’ll look into this shortly.

But as of right now, none of the CHIP Pro images are available for download and flash through the CHIP-SDK. You can build your own Buildroot or Debian image and flash it with these scripts, but as far as flashing pre-made CHIP Pro images go, currently that has to happen from the web flasher.

– Ben


Success in Flashing C.H.I.P pro from Ubuntu 14.04
#9

I have the same problem. I am not able to flash the build root as well. Any solution would be greatly appreciated.!


#10

My solution was to forget abandon the (unmaintained/deprecated?) vagrant VM, and compile/flash with Ubuntu (well, Linux Mint 18 as that’s more my taste) running directly on the hardware. Made all the difference! Use the ubuntu setup .sh file in the vagrant repo to install all the package dependencies and the git setups.