Video and power issues with CHIP


#1

I just received my production CHIP yesterday (12/27/15). I was excited to get started, but have some issues off the bat. First, I know it is only composite video, but it really looks horrible on the two tvs I have tried it on. It is very grainy and full of scan lines. I have ordered the HDMI and VGA cables with my package to be delivered in Spring 2016, but is there anything else I can do? It is nearly useless at this point.

Also, I am experiencing a power problem. CHIP shuts itself down after a few minutes. I mean, shuts down. The power lights go off. I need to unplug and replug CHIP to get it going again.

I was hoping for something more from my $100+ investment.

Thanks in advance.

Bill


CHIP won't boot with USB soundcard
Someone please help asap
#2

How are you powering your CHIP? If by USB, what is the USB cable plugged into?
What is plugged into the USB port on the CHIP? If it is a hub, does the hub have it’s own power or does it take power from the CHIP? If it takes power from the CHIP, what is plugged into the hub?
Is WiFi Active?
Is Bluetooth Active?
Are any components on the board getting excessively hot?


#3

Wow more stories of them shutting down. Was the R8 even tested vs the R8M? I imagine the power draw is a lot higher with the separate flash and all.


#4

Hi @Android, I think it is something else that the change of the package.

I have experience the same problem and I have tried out different power supply, even 5 Amp power supply and still it shutdown after few minutes, some times it never fully load the GUI. As @wyzzard47 mention the only way to get CHIP working again is disconnecting the power and connecting it back again.

I have open a topic about this problem on the forum yesterday, but looks like still nobody find out the reason.

– volkan.


#5

I’m having similar issue:
I’ve powered it on after arrival and it worked fine (the composite video looks horrible, but whatever).
So I’ve setup Wi-Fi connection using USB keyboard/mouse and rebooted CHIP.
After reboot both LEDs are ON on the CHIP and there is nothing on the composite video.
Tried to reset using button, powered it OFF/ON multiple times, changed USB cables/power supplies - nothing.
So I’ve connect UART cable and there is all what I get after reset:

U-Boot SPL 2015.10 (Nov 25 2015 - 20:46:36)
DRAM: 512 MiB
CPU: 1008000000Hz, AXI/AHB/APB: 3/2/2

#6

Is it possible the power management IC thinks a battery is connected and fully charged? And is shutting off the USB power? Have you tried running off battery power?


#7

No, I don’t have a battery to test it. But I already order a set of battery from Amazon which should arrive before the weekend.


#8

Instead of powering CHIP using the microUSB port, try using the header CHG-IN (U13-2) and GND (U13-1) with your 5V 5A power supply. It can source more current from the CHG-IN than from the microUSB port.

Or use a combination of the microUSB port and a battery.

CHIP can utilize power from three different sources at the same time:

  1. The microUSB port (USBVBUS)
    2a. The white JST PH-2 battery connector J1 (BAT)
    2b. BAT on header U13-8 (BAT)
  2. CHG-IN on header U13-2 (CHG-IN)

The CHIPs uses the AXP209 power management IC to manage power usage from these sources.

With the CHIP Alpha, it appears the AXP209 is limited to sourcing a maximum 500mA from the microUSB port. Users have reported that when powered by the microUSB port only, CHIP could not handle large loads on the USB-A port and shuts down. This was was solved by supplying additional power with a battery or by using a externally powered USB hub.

Assuming powering the CHIP is not the problem, tracking down reasons for high temperature shutdowns would be next.


#9

Good suggestion, it is possible that whatever device is being used to power the CHIP could be detecting the lower idle current as being unplugged and shutting down power to the CHIP. The unplug/replug likely resets the power supply.


#10

I too received my CHIP this past Christmas week, and tried troubleshooting today…
At first my CHIP would just show the series of startup checks aka the boot-up text and would shut off as soon as it reached the end. It would constantly shut off, I attempted to try different outlets, different tv’s and it would continue to shut off at the same spot.

I finally used a samsung “FAST charge” usb power plug and it did a good enough job to get me to the main desktop. I tried plugging in a usb dongle to no avail since it shut off my CHIP, I’m assuming that the devices plugged in took away power from the CHIP itself.

I proceeded to physically switch out the USB receiver for the keyboard and mouse when I needed to use one another. Until that moment everything seem to be staying on, until I used ice weasel to surf the net and then BOOM it shut off once again.

I started feeling around the CHIP itself and felt that little machine was HEATING UP…So my best guess is thermal shut off, where the CPU gets super hot and it decides to shut itself off so it won’t fry itself.

Any ideas besides the obvious heat sinks?.. Maybe a NTC (Next Thing Co) certified power supply? A new case allowing air flow? What can I do?? Maybe getting a Pocket Chip will help keep this little guy alive?


#11

Hi @StaticComputer, I’ve experienced the same problem than you. However I was able to surf the web for a while, but never manage to get the CHIP running more than 10 minutes. I use a 5A power supply, so I’m positive it is not a problem of lack of power from the power supply.

I think, it is something with the firmware itself. As the new processor for CHIP R8 in theory should use less power that the combo Flash+RAM+Processor of the R8M. That was one of the reason they put the processor under the card with the RAM.

I hope somebody in the kernel hacking community soon find a fix to this problem.

– Volkan.


#12

Are you feeding in via MicroUSB or are you feeding in via the CHG-IN? I suspect more power may be available if you feed via CHG-IN, but I’m far from sure.


#13

Just to add in I’m having similar problems with Ice Weasel, except it barely boots into ice weasel then dies. It restarts just fine but ice weasel kills it. I’m using a 5V 1Amp to power mine, with external powered usb hub to power the mouse/keyboard. I thought I ran across something that CHIP draws a max of 300millamps on boot but normally operates at around 100. I’d think one amp should cover it.


#14

The reason is simple, the PMU is overheating/over current since ALL the power for everything on CHIP must pass through it. Look at the schematic, if they move the power feed for the stand alone LDO regulators to the three power sources with blocking diodes that would free up 3000ma of load bringing the power load on the PMU to just under it’s rating. Other vendors use PMU’s but they all use the PMU enable signals to control discreet LOD regulators, NOT power them.


#15

Hi @KevinA

Thank you for the explanation. I didn’t see the schematics, I was thinking is could be a software problem, not a hardware issue.

Few question: why was not it notice with the alpha production cards? Is there a way to fixed in our productions cards without solder anything in the card?

Some people was recommending provide power to the CHIP using the CHG-IN (U13-2) & GND (U13-1) pins, should it solve the issue?

What will happen if I connect CHG-IN/GND to power and also connect the microUSB to a computer?

Thank you.

– Volkan.


#16

@volkan68 It will use both, the CHG-IN/GND first and additionally the microUSB if needed.

From the AXP209 Power Management IC Datasheet, page 17:
Note that VBUS is the microUSB port and ACIN is CHGIN.

9.2 Power path management (IPS)
The AXP209 power input can come from lithium battery (BAT),USB VBUS Input, external power supply (ACIN). The IPS will select an appropriate power source depending on the battery and external power conditions.
O When only the battery is available, no external power input, the battery powers the system;
O When there is a valid external power source(VBUS Or ACIN), is is the preferred power supply.
O When the external power is removed, the IPS will seamlessly switch over to battery power.
O When both VBUS and ACIN are available, ACIN will be used to power the system and recharge the lithium battery;
O If the ACIN cannot provide sufficient current, VBUS is also connected to source more
current;
O If the drive capacity is still insufficient, then the charge current is reduced to zero, the
battery is used to power the system.


#17

CHG-IN & GND seems to resolve the issue. I ran into the same issues, but have been running it off of those pins and has been working properly.


#18

Does anybody know why some CHIPs (like mine) work fine with a weak-@ss micro USB charger, while others need multi-amp supplies connected to CHG-IN? Would different boards draw different currents? Maybe some people aren’t using a powered USB hub for their keyboard/mouse? Might the ambient temperature play a role? I keep my house temp around 63 F, maybe those with warmer room temp are getting overheat when using only the micro USB?


#19

I think it’s more the variation in the chargers themselves. I’m really amazed that NTC doesn’t have an “officially supported charger” considering how bad some “USB chargers” are. It’s one thing to provide power to a device that has a stable voltage reference (a battery). It’s something else entirely to provide the only voltage source a board has.


#20

I think you may have a point, USB chargers tend to be noisy, especially the cheap ones. I’m sure a genuine Apple iPad charger would be a lot better than a lot of the other ones. If the USB pins were easily accessible I would suggest maybe putting a 1000μF (may need more, may need less) electrolytic capacitor across +5 volts and ground to dampen current peaks from the CHIP.